Disable Scroll lock


I’m not sure if it was a recent change in Libre Office Calc; I didn’t have this issue previously. My current version is:

I’ve a backlit keyboard, and the lighting is toggled by pressing the scroll lock key. Is there a way to disable scroll lock in calc? When I use calc, I tend to use the arrow keys to move the cursor around, and now it moves the page instead. I’d rather not have turn off the light feature on my keyboard just to get the ability to move the cursor.

Thanks in advance!


Currently that’s not possible.

Thanks very much for the response. Do you know what changed? I’ve been using libreoffice for a long time and it was never an issue before.

Again, appreciate the answer.

As the first link I provided shows, there was a long-standing enhancement request to “Use the Scroll Lock key as a toggling lock key like Excel”. It was implemented for 5.3, and so now it works as you see.