Disable substitution in Writer definitely, once and forever

I disabled Automatic spell checking.
I disabled “While typing”.
I disabled each option in the Options tab of AutoCorrect.
I disabled each option in the Localized Options Tab.
I disabled Word Completion.
I even deleted all substitution lists I could find. I don’t remember what I deleted, it was some months ago, but all lists in the Replace, Exceptions and Word Completion tabs are completely empty now.
Nevertheless, I type “Nr” and the writer writes “Nr.”.

What else could I do? Is it asked too much for Writer to simply write what I type?

This list here is even worse: in the entry field for questions, “Nr.” is substituted by something like “No”, but in the published text, the original “Nr.” appears.

What do you mean? If you type <letter_N>, <letter_r> and <dot> and you get Nr., where is the error?

Edit your question to improve its description and make clear what’s happening.

Probably the questioner wanted to get "Nr". and got "Nr." (including the quotation marks)?
Can there be an extension like for syntax/grammar check producing such an effect?

It would be also useful to know the text language, LibreOffice version, platform, etc. to try to see what is happening. E.g., I can’t see this with en-US using on Windows 10, when I simply disable While typing and Automatic Spell Checking.

Probably you have another similar language in your document. The AutoCorrect settings are per language.

Rather than turning everything off in every language why don’t you just set the language of your documents to None?

image descriptionIt is more complicated than I thought. Clearifying:

1. Old writer document

This document is an empty letter, which just contains header, date and so on, but no letter text and I use it as template. I wrote it 10 or 15 years ago. When I type there “Nr .”, without the space between ‘r’ and ‘.’, I get ‘N’ followed by a special character, together looking similar to ‘N’ followed by an undelined ‘o’.

2. New writer documents

In new writer documents it works as intended, no substitution.

3. Here on this site

Here it is really weird:

  • In the field where I am typing my question, substitution takes place as described under point 1.
  • The published text shows the original text instead, without substitution
  • In the comments, no substitution takes place, neiter when typing, nor in the published text.


With the discovery that new writer documents behave as expected, I consider the problem as solved, I will write a new template for my letters.

But the maintainer of the site should have a look at point 3 above, which caused the confusion reflected in the comments.

Thanks for your responses.

Screenshot about behaviour on thsi site added.

I would actually doubt that conclusion … couldn’t that be something system-specific? It’s not something that numerous contributors see here.

Tried it, nothing shows up that looks like what you do. Screenshot please. And please: Don’t be so sure that it isn’t all really something you do wrong in the first place.

There is something strange with this post. If you click on edit under the question, you see `“Nº” (LATIN CAPITAL LETTER N, MASCULINE ORDINAL INDICATOR). It is displayed as “Nr.” with U+00BA replaced by r and a dot!

I could not replicate this. But a close examination of the question code reveals that the N + ordinal indicator has not the same shape as the Nr. preceding it. Copy & paste from Writer which kept some formatting? Anyway, this may have been entered into AskLO database and the HTML editor does not reflect it: there is no <span> or other formatting in the page HTML to change the font face. Such a change may eventually not surface in the editor box.

Strange indeed: I can’t see that (I tried editing the question from the start, and I do not see what @ajlittoz describes, using Chrome on Windows 10). Is it some OS feature? Specific to some Linux flavor? Then it could be something out of control of LibreOffice…

but then, as OP writes in #2, it doesn’t happen in a new document. Font-related? Ligatures?

Using Firefox 86.0 under Fedora 33 with KDE Plasma 5.20.5 - kernel 5.10.21

But if you copy’n’paste the sequence, it comes as Nr., without the ordinal.

Firefox 86 on Ubuntu 20.04.2 LTS and I don’t see it either.

Added a screenshot as requested. Platform is Linux Mint 20.1 (based on Ubuntu 20.04) with Xfce 4.14.2 and Firefox 86.0. As I said, the problem with Writer documents I consider as solved, as it appears only on a pretty old document. I wouldn’t call the behaviour of the site an urgent problem. The maintainers shall decide what to do.