Disabling "smart" cut and paste

I start with the text “alpha beta,” select “beta”, and press CTRL+X. The space after “alpha” should remain, but instead I get “alpha,” (with no space). Why would it remove the space?

Now, without moving my cursor (so that it is still between “alpha” and “,”), I press CTRL+V, and I get “alphabeta ,”. Why in the world would it insert a space before a comma?

Please tell me how to disable this “feature”, because I do a lot of copying and pasting and it is incredibly annoying. I have unchecked all AutoCorrect exceptions, options, localized options, and word completion. I have also unchecked “Word-compatible trailing blanks.” Yet this still occurs.

(This is Writer version on Windows 10)

The effect seems to occur during cut when it removes the extra space between words or between a word and punctuation. The workaround appears to be to cut the space before as well.

You could post it as bug

Workaround: Use DEL key.