Display anomalies when resizing columns in calc (Mac Catalina)

In Calc, when I resize a column (click on the divider between columns and drag to change its width), there are some significant display anomalies, even before I start to drag. This started (I think) with version 7.0, and persists in Mac Catalina. It happens every time I resize any column in any spreadsheet.

In my sample image, I’m resizing column C; there is data in column D but you can’t see it because the anomaly (wide grey space between the two columns) covers it entirely.

No issue on my Xubuntu box. Have you tried to play with the Preferences > Options > LibreOffice > View options for Graphics Output?

To show the community your question has been answered, please tag the best answer (), and/or vote for any helpful answer. Else, please edit your question to add information (answers are for solutions only).

I see two options under Graphics Output: Use hardware acceleration (which is greyed out), and Use anti-aliasing (enabled). I unticked the anti-aliasing box, quit and restarted LibreOffice. The problem persisted.

Could be the problem only affects Macs, or Mac Catalina?

There would be much more posts about that here I guess.

You can try to reset your LibreOffice user profile (rename it).

I tried something a bit more thorough: I created a new user account on the machine. That gives me not just fresh LibreOffice settings, but fresh OS settings as well, in case something I did to customize appearances was causing trouble. But the problem persists even with a new all-defaults user account and new LibreOffice settings.

Added Mac Catalina to the subject in hopes of attracting comment from other users of that system.

You can try to search the bugzilla and file a bug report if nothing reported yet.

Especially if it does not work with factory settings for both the Mac profile and the LO profile.

Tracked as Bug#142061

I doubled the bug report, since I couldn’t find #142061 in Bugzilla.

I installed two days ago, with version 6.xxx I had no problem of that kind.

My config: Macbook Pro Retina late 2012, OS X 10.14.6 Mojave, dark appearance.

For tracking of the bug: it shows either blank or the area left and down of the originating pixel where you place your cursor, enlarged by 400% right & down to the bottom menu strip, shifted left by 91px and tinted pinkish grey with lessened contrast. This happens only with the first attempt, repetitions result in blank display anomalies.

See screenshot, checked in PS respectively Affinity Photo:

have same issue with Big Sur Macbook Pro 2017, all ok in 7.0.6 version looks there will be no help no solution… time to say goodbye?