Display resolution gets reset on Windows 7

I am running the latest still (5.1.5) downloaded today. The installation completed smoothly. The first time I go to run LibreOffice I am prompted for user account privilege escalation. After I give authorization, the program resets my display resolution to be 640x480 and 8-bit color. I am able to re-set the resolution manually, but the LibreOffice window still looks as though it was laid out in 8- or 16-bit color.

Sometimes interacting with the menus or dialogs will spontaneously reset the display resolution to 640x480 without warning.

When I exit LibreOffice, the screen returns to its normal resolution.

Prior versions of LibreOffice were working fine, but this behavior started after upgrading to the latest version.

I tried uninstalling and reinstalling, to no avail. I tried upgrading the laptop’s video drivers, to no avail.

Please help! this is my mother’s computer- all she wants to do is work on her documents. She is very superstitious about upgrades, and this situation does not help.

Note: when opening individual files I am receiving “The requested operation requires elevation” error, as discussed "the requested operation requires elevation"? and elsewhere

FYI, I discovered that the system did not have Windows 7 SP1 installed (still doesn’t- it won’t take for some reason) but the system being extremely out of date may explain the problem

Try resetting your profile first and then checking the file permissions as described in the post you mention in your comments.

Note that re-installing LO does not change user profile.