Disturbing error message


I just saw my LibreOffice crash. When I started it back up I got this slightly disturbing error message:

Either another instance of LibreOffice is accessing your personal settings or your personal settings are locked.
Simultaneous access can lead to inconsistencies in your personal settings. Before continuing, you should make sure user ‘myname’ closes LibreOffice on host ‘18742179034.3g.telemar.net.br’.

Do you really want to continue?

Now, I moved from my home to an internet café but the message does suggest some kind of malicious thing going on. Anyone care to comment?

Kind regards,

Please indicate your operating system, LO version, and more detail about what your configuration / installation is. Do you have two different copies of LO accessing the same user profile? Are you accessing the same file over a network?

Interesting. Same error even after a reboot. I have Mac OS 10.9 Maverick and LibreOffice No to the different copies. It’s just on my computer. I’m wondering if I could have accidently opened a file from a mounted zip file?

Thanks for the information. It sounds like LO has accessed your user profile and the process has still been running (not terminated properly) when a second instance has tried to again access the user profile. There are some technical details in this AskUbuntu thread on possible ways to go about fixing the issue. The mounted zip file may be related. Mounts have a bad habit of getting stuck and locking a related process.

Has this problem been resolved yet? I’m still getting the error message regarding “another instance” and “personal settings” whenever I open LibreOffice. It’s Aug. 3, 2015 now. Using the latest version of LibreOffice on a Macbook Pro running OSX Yosemite.

I don’t think it’s resolved, but http://apple.stackexchange.com/questions/113189/libreoffice-error-either-another-instance-of-libreoffice-is-accessing-your-per has the correct answer for how to solve this on Mac. On the current instances only the file ~/Library/Application\ Support/LibreOffice/*/.lock seems to be relevant for now.

I’ve experienced this following a crash, with an important twist. First, some relevant info:-

  • Filename: html5.odt
  • Lock filename: .~lock.html5.odt#
  • Lock filename contents:

    (my-name),(network-name),(computer-name),(date),(profile location);
  • the lockfile contents were used to give me a message explaining why LO/OO would not open the file for me after the crash

The crash was under Windows & was the early signs of the hdd breakdown.

The error message was under Debian.

When the lockfile was removed (located in same dir as odt) the message continued.

When an identical lockfile (different name) was removed from the profile, I got access back to the file.

Unless you are ‘myname’ in that error message, then you need a firewall installing (possibly a good idea anyway).

If this helps then please tick the answer (:heavy_check_mark:).