'document recovery' succeeds, but then throws an 'unexpected error'...[solved~workaround found]

LibreOffice, editing a .docx file in Writer, saved the file, closed the file, rebooted the computer (installing another program), tried to reopen the file to continue working and I got the ‘Recovery’ dialogue. OK, recover it for me. It does, I can see the green checkmark and even the file opening in the background, and then an error appears that says, “Due to an unexpected error LO crashed. All the files you were working on will now be saved. The next time LO is launched, your files will be recovered automatically.” All I can click is ‘OK’, which starts ‘Recovery’ again. Which is where I started… Another possible clue: a dialogue that said, “SEH Exception: ACCESS VIOLATION”.

I can open the file with my Microsoft OneDrive account, and all my edits are intact, but unfortunately I can’t save it in a different format… :frowning:

Any hints? Suggestions? It would be really nice to be able to recover this file!

I would inspect the security controls for the file, in advanced mode. Now this all is complex and hard to understand, but if you chew on it enough to know what each thing there means, it might help you. To me access violation, sounds like it can’t access a file or directory.

I sent the .docx file to a friend who has MS Word. He opened it, saved it with a new name, and sent it back to me. That did the trick. I still have no idea why LO choked on it, but I guess we can mark this [solved]–at least for those with friends who have MS Word… It would still be nice to know what an “SEH Exception: ACCESS VIOLATION” is.


SEH Exception: ACCESS VIOLATION is not a specific error message; SEH stands for Structured Exception Handling (a technology used in Windows OS).

If a file is openable with MS Office, but fails with LO, you may file a bug report at bugzilla. You should attach the problematic document to the report, and state which LO version have you used.

This could help us to improve LO. Remember, however, that the document would be publicly available.

Thanks for the info, Mike. Normally I would submit a bug report, but since the document in question is a co-authored paper for possible publication, I’m hesitant to do so…

I had an identical problem with the same version of LibreOffice that came with the installation of Kubuntu 18.04. As a layman I went to the most radical solution: I removed LibreOffice via Discover and downloaded LibreOffice 6.0.1 from this address: https://en.libreoffice.org/baixe-ja/?type=deb-x86_64&version=6.0.1&lang = en-GB. I unpacked it, got into the DEB subfolder, gave dpkg -i * .deb. Once installed, I came across a beautiful LibreOffice 6.0.1, working wonderfully well.