Double letters in Manjaro

Not all of Manjaro (KDE), of course, just Libre Writer. When I type, whatever I type is doubled. “Ttiiss iiss aann eexxaammppllee!!” This affects numbers, Backspace and Return as well. I have not seen this before with any other Linux Distro or Desktop. Indeed, I was able to work just fine with this combination when it was first installed. I’m going to post this on the Manjaro forum as well. I’m new to Linux as a full time option, so I have no idea if it’s a common problem, or if I’m making computing history. I’d prefer not re-installing anything if there’s a simple solution.

Thank all, in advance.

Hello, may be you should check the delay value of your keyboard. Go to KDE -> Settings -> Manjaro Settings Manager and select Keyboard in category Hardware. Set the Delay value (slider at the bottom) to some higher value (I think the default is 600) and click to Apply button. Check again in LibreOffice.

Hello, I am with the same problem. I tryed to modify the delay, putting the max value, but the problem continues…

Now there are three people, but none tells at least his/her LibreOffice Version and which packages are used - Just a hint: There seems to be a problem with virtual keyboard on KDE - disabling should fix the problem. Thus my question: Are you using onboard virtual keyboard?

I’m using LibreOffice, KDE Plasma 5.16.4 and Linux kernel 4.19.69-1-Manjaro. I have the same problem after last Manjaro update. Please, any idea to solve?

I’m having the same problem. I’m currently running Manjaro with Linux 4.19.79-1-MANJARO, Libreoffice 6.3.2-2 and KDE Plasma 5.16.5. I’ve tried playing with Keyboard Delay and Rate on Manjaro Settings Manager to no avail. The only thing that fixed (as a workaround) was exporting SAL_USE_VCLPLUGIN=gtk3 or SAL_USE_VCLPLUGIN=gen, but it messes with the Libreoffice L&F too much. Any ideas?

Same issue here, same solution of the guy above.

Until now no one ever commented on my hint about onboard virtual keyboard

I use libreoffice Version: - Build ID: 6.2.8-1. Manjaro 18 - KDE version 5.17.1.

I use LibreOffice Version: - ID Build: 6.2.8-1. Manjaro 18 - KDE Plasma 5.17.1 kernel 4.19.80-1 and I have the same problems. I tried the hint from Opaque, changing the keyboard speed, and the problem remains. Reinstalled libreoffice stable version. No changes.

@pgborges’s comment states that forcing the VCL plugin seems to improve the issue. This reminds me of bad behaviour I experience when I last reinstalled my computer from fresh. My distro is Fedora with KDE desktop. I wasn’t cautious enough and didn’t install the plugin consistent with the widget collection used by KDE. KDE uses the Qt library. Consequently, package libreoffice-kde5 must be installed (but not -kf5 if it still exists). Names may vary in ither distros.

Please check this plugin issue.

Same problem here using UBUNTU. Actually, the double letter issue happened to me just once and went away without me doing anything. Now, the issue is happening only when I use control+ANYTHING commands: the action is done twice. Only in LibreOffice.

I have the same problem. Can anyone help us?

Which question is addressed by this “Answer”… please do not use Add Answer on this site, if you actually don’t answer a question. This site is designed for Q&A. Thanks in advance …