Downloads of LibreOffice suite always fail no matter when I try

I have tried a million times to download the latest updates of LibreOffice over the past few months. I have Windows 11 and use Firefox browser. I am downloading Windows 64-bit version. Each time I try it starts and downloads most of it but then says ‘download failed’ after I have downloaded almost the entire thing (ie at 330mb + ). I am left with PART files on my computer. I am on 15GB a month data plan and it wastes my data to keep doing this. Does anyone know why it continually fails? I last succeeded in December 2022 so a while ago.

I have no idea why could this happen to you; but there are some things you could try.

  1. It is very likely, that every time you use the same mirror to download the installer - the mirrors are chosen using geolocation, so for a given location, the same mirror could be offered again and again, even for different versions. You could try to pick some other mirror manually the next time you try to download: on the download page, there is an “Info” link, that will allow you to do that:

  1. You might try to use another download manager, instead of the one in the Firefox. E.g., use another browser (Chrome?); or a third-party downloader.

  2. You might try to download using torrent.

  3. You could try to disable antivirus for the duration of the download - but that is risky.

1 Like

Hi mikekaganski,

Okay, I combined two of your suggestions and used Edge (don’t have Chrome) and looked for a mirror under the Info button - this time was able to complete the download and install. Brilliant. In the process I discovered my previous successful attempt at download was actually in June 2022 and not December 2022 as I said in my post - the December download I saw on my PC was also only a PART file which hadn’t worked. So it’s nice to be up to date finally.

Don’t know for your settings, but “long time ago” I needed to adapt energy settings, as my OS sent the device to sleep after some time, before the download was complete.