Drag&Drop not working in LibreOffice 6.2.2

I have LibreOffice 6.2.2 installed on KDE-Neon and I note that Drag&Drop is not working in either Calc or Write.
Is this possible a reemergence of the historical Qt issues?

Hmm - for me that works at least for the case “Drag & Drop a JPG image”. So it might be a special use case and you need to be more specific

My Configuration:
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5;
Locale: en-US (en_GB); UI-Language: en-US
Calc: threaded

It appears that some things work: for example a text box can be readily dragged and duplicated in Draw. What I am having difficulty with is selecting and duplicating phrases in Write using Cntrl Drag&Drop and a similar situation in Calc. I know I can do this with cut and paste but drag and drop is a lot more convenient.

Full Config:
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.20; UI render: GL; VCL: kde5;
Locale: en-ZA (en_ZA.UTF-8); UI-Language: en-ZA
Calc: threaded

Ok - so I cannot help. I never even tried to Drag&Drop text from one application to another. I’m even not aware of any application where this should work, cause Drag&Drop for my understanding works on objects like images, OLE object, other application but not on data (number, text).

I think he’s talking about drag and drop within an application. I know about this as a general GUI idea, though I can’t recall using it in LO. Trying just now on Kubuntu 18.10, I get the cursor to change, but nothing changes on drop. Both drag and ctrl-drag work as expected in Kate, so there’s definitely something going on with LO if it used to work there too.

I think this is a problem with the VLC plugin. The KDE plugin was recently updated for KDE5, so I tried GTK with:

SAL_USE_VCLPLUGIN=gtk3 lowriter

And both drag-to-move and control-drag-to-copy worked. If you don’t mind the slight oddities that come from mixing GTK and KDE, you might install the package libreoffice-gtk3 and launch libreoffice as above. You can even add the environment variable to the .desktopfiles for the applications menu (I had to do this in the past to solve a problem with Calc with the KDE4 plugin, which appears to have been removed.)

I would encourage you to test this on your system and submit a bug report.

Hello. I will try and revert.