Draw always resizes everything proportionally

After working in Draw for a while, and apparently changing some setting, all resizes started to be proportional. I now need to press Shift for them to not be proportional all the time. How can I revert to the original behavior?

I searched the web, the help wiki, restarted Draw, created a new drawing - to no avail.

This question seems to describe the same problem, but with Impress: Impress: Resizing Elements using the mouse causes proportional resizing unlike any other software

After messing around for a while I found that the responsible option was “When creating or moving objects” from Tools->Options->LibreOffice Draw->Grid->Snap Position.

I toggled it while trying to make grid snapping work the way I expected it to and it appeared to make a positive difference. Due to the option name being non-obvious I didn’t think it might affect my problem. The effect it has on resizing still doesn’t make sense to me, even after reading the description: Grid - LibreOffice Help

In LO this is accessible in Tools → Options → LibreOffice Draw → Grid → disable “when creating or moving objects” text box. Then select apply and okay.