Draw: general input/output error while saving document

LO under Fedora 25

Whenever I try to save a Draw document, I get a general I/O error. After dismissing the alert, the Draw window becomes frozen, it won’t close, its menus do not respond. Although clicking on the close button in the window bar does not even trigger the system “window not responding, kill application?” dialog, I can grab the window and move it around. Other LO windows (Writer or Calc) are unaffected and continue to work.

Only to close the window is to disconnect to reopen a session.

Since I performed a recent update, I wondered if something in the format of my existing files was at stake (can’t remember LO version when they were created). To clear the point, I created a blank Draw document and tried to save it. I get the “general I/O error” with that blank document too.

Writer and Calc documents can be modified and saved without trouble.

I cleared my user profile to no avail.

Any idea?

EDIT 2017-03-28

It doesn’t look like a profile issue because I created a brand new user and tried to save an empty Draw file. I got the message and LO was frozen afterwards. I must kill it manually.

I have the exact same issue!
LO under Ubuntu 16.04

Does this happen with any target folder (where you have write access rights) and any file name? Do you use the system file dialog or the LO file dialog? Do you try to save as odg or a different format? Does it happen to presentations too?

@regina: any file and directory

system/LO dialog? I save through File menu. Therefore I get whatever menu LO chooses to use.

I always use odg; I didn’t try Impress because I have no need for it presently.

I’ll make other tests later today with an updated LO version

I had the same issue with veriosn on Ubuntu 16.04 LTS.
Simply installing libreoffice-impress solved it.
The relevant bug report:


Alas, not relevant for me: I always install the complete LO collection

The link in my answer mentions an investigation technique: start draw with strace and check the output for errors:

strace -ft /usr/lib/libreoffice/program/soffice.bin --draw

There might be too many errors, but the time stamp might be helpful to find the relevant.

libanimcorelo.so is present in …/program/, so need another lead