Draw: PDF glitched font

Hello, I’m trying to fill a PDF in Draw but the font is misaligned. I checked 7.6 windows and 7.3 kubuntu, both glitched. Firefox and Okular display the PDF correctly. Is it a missing font, bug, or am I doing something wrong?
Link to the pdf (I can’t upload a file):

I could not see any problem for filling in the data (LibreOffice Draw; MasterPDF-Editor). I copied a text box and filled from anew.
For the fact that the ArialMT-font family is included in the file, this may cause some problems in some environments. The PDF file was produced on outdated Corel Draw X5.
Linux: Open the PDF file on evince or similar PDF viewer and print/save as a new PDF (which will hopefully replace some fonts) and then try again to fill in this new PDF.
Note: This official “form file” seems to be a simple PDF file with no form objects inside. It is obviously made for manual filling.
– Cheers

Thank you for your advice, unfortunately no success. I tried a few viewers and their printing options and it sometimes was even worse. And Okular says the printed files have indeed embedded fonts but rendering in Draw is still broken.

I would like to put text on top and Draw has these options like font kerning so with mono font I can fit letters in these boxes.

Filling itself works well, but existing fonts are misaligned
Left is Firefox, right is Draw

For difficult proceedings like yours I probably would use those 2 work arounds:
1st Open the PDF file on Inkscape and test different options of Internal import. For very renitent files apply the Cairo import option.

2nd Open the PDF file on GIMP and use a resolution of approx. 300 ppi/dpi. Then cut and paste different parts. When the ground layout is finished you could import the image (preferably in PNG format) in Draw and add text boxes…
– Godspeed

1 Like

I am in Windows 11. I opened the PDF in Adobe Reader, selected Fill & Sign, it made it into a form and I could fill in the fields OK. I believe Adobe Reader can be installed on Kubuntu.

1 Like

Good idea. I tested a similar procedure on PDF-XChange and Foxit PDF Reader and it worked as well (Windows programs installed on Linux Wine). Inserted texts were saved without “rendering” problems…
It seems that the questioner would like to alter the PDF’s layout (I don’t extactly know…). In this case you have to “rip” the PDF file as suggested…

1 Like

There is an issue with justified paragraphs which aren’t rendered as justified. I think this bug covers it, Bug 49705 - Recognize the alignment for paragraphs/text blocks in imported PDFs

Opening the pdf with Inkscape, as @Grantler says, gives a much more accurate rendering of the pdf. It even uses ArialMT font which neither Draw, nor Illustrator 15.1.0 implement. ArialMT is slightly smaller than Arial, substituting with Carlito font might work.

1 Like