Drop Down in cell

I have a calc cell that has started displaying a drop down list with several selections above a list. The selections are:
Sort Ascending, Sort Descending, Top 10, Empty, Not Empty and Standard Filter. There is a text box for Search items…

I seem to not have enough points to include or attach a screen capture. Has anyone seen this? What is it? How do I get rid of it?

Libreoffice Calc version
Ubuntu 16.04
Cinnamon 3.0.7

Thanks, as always, to anyone kind enough to help!!

Select the cell and uncheck Data > AutoFilter option.

More info about AutoFilters:

Thank you so much. I’m fairly certain I tried that. What I had not done was close and then reopen the file. When I just opened to try your solution - it was gone.