Dropdown disappears when I mouse off

Libreoffice About:
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group

uname -a:
Linux Figment-II 4.15.0-42-generic #45-Ubuntu SMP Thu Nov 15 19:32:57 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

Gnome version: 3.28.2

So this is a weird one. It only started recently, so it may have been triggered by an update of something. If I go to the data validity of a cell, and put in a list of options to make a drop-down, the drop down appears exactly as expected. And when I click it, it drops down and shows the options. So far so good. But then when I move the mouse to go select one, or even a single pixel, it immediately closes! I can, however, use the arrow keys to select an option, and that works fine.

So I searched around a little and there was the suggestion to disable OpenGL for a problem that seemed vaguely related. So I went hunting for an option to do that; no luck, but I did find, in Tools Menu → Options… → LibreOffice → View, 2 checkboxes: Use Hardware Acceleration and Use Anti-Aliasing. Both were checked. I tried unchecking the first, and it worked! Exactly once. I went to select an option with my mouse, and it succeeded, so I tried again…and the old behavior was back. I tried cycling the checkbox, but couldn’t get it to work again. So I tried the Anti-Aliasing box, same thing all around: worked once, couldn’t repro again. I’ve tried jiggling the boxes, and it occasionally works, but nothing permanent.

So, does anyone have an idea about what could be wrong or what to try?