Editing fields in LO Base became unavailable, why?

Using LO on Windows 10 Pro, connected to an ACCDB file. I used to be able to add and edit fields directly in a table or from queries against that table, but recently editing became unavailable. The basic table still shows the ID field as the primary key. The symptoms have varied. At first, I got error messages from trying to save queries after doing edits, but the Edit Field command remained available. Using that still didn’t let the edit register (as I recall, it just went away); then the command became unavailable. I’m trying to test changes to the table design (it’s a legacy basically from 2006) and I need to add fields and set their content.
The file has not become read-only; I can create and run new queries, for example. But I can’t change contents of a field. Any help on what’s happening?

I have no Windows and no accdb file at hand right now. I guess, there is some file locking problem.

  1. Close the entire office suite (mind any “quick starter” in the system tray).
  2. Make a copy of the accdb file.
  3. Open the database document, call menu:Edit>Database>Connection… and connect to the copied accdb.

Interesting! Edit>Database>Properties and navigating to the copied file worked, so there’s apparently a level of locking below the file level (since I was able to create and run new queries before). Thanks for the help!

Oops, spoke too soon. Same problem recurred, and this time neither the old copy nor the new could be edited once I did the successful update I referred to in my earlier post. I really need to know what’s happening here. I was theorizing that maybe updating the basic table with a query that also referenced its primary key was responsible, but this time I was trying from a different query that didn’t do that. The Edit Field command shows as unavailable. The basic table still shows the ID field as the primary key.

You are working with 2 programs, LibreOffice as frontend and some database driver as backend. DIsconnect the database before you shutdown the system or close the lid of your laptop. There is an actively developed alternative driver for Access databases which works on all desktop systems: UCanAccess-A Pure Java JDBC Driver for Access

Thanks! I downloaded some Windows tools from Microsoft that may actually be in the picture here, I was having problems connecting at all and tried anything I could think of. I’ll check into UCanAccess, too. It would be nice if it got at the queries, forms, and reports, too – what I see with Base is tables only. Lots of them, maybe one per query in addition to the regular tables? I’m not sure if that was done as part of establishing the connection, or if they are there in the Access file. Anyway, none of the other components are visible. I really appreciate the help, this thing is driving me nuts.