Embedding Fonts in 6.4

All of my free, open source mathematics texts and workbooks are created with LibreOffice. I had been using 6.1 but updated to 6.4. I use a publisher (lulu.com) that requires the fonts to be embedded. I selected embed fonts but can no longer upload pdfs. I am told that fonts are not embedded. I have tried creating the pdf from LO writer 6.4 on my Linux desktop and on my university’s IBM-clone laptop. I receive the same error message from their server: “Fonts may not be embedded.”

There may be a different issue. For example, Lulu also has a list of other features that the exported pdf must have:

Images should be 300 ppi resolution
All fonts should be converted to outlines and embedded 
Flatten any transparent layers and vector objects
Do NOT use any security / password protection
Set compatibility mode to PDF 1.3 (PDF 1.3 does not support transparencies and will flatten them when creating the PDF)

Thank you so much for your time and expertise! --Ben

edit: activated screenshot -AK

font embedding in the document likely does not relate to PDF export, only to embedding in ODF (and possibly OOXML); PDF font embedding must be independent… However, the PDF version could lately be bumped (see LibO 6.3 creates PDF v1.5, but LibO 6.4 help says it is v1.4), which might be possibly the problem…

I also was not able to embed fonts with in PDF exports. My workaround (to prevent errors in Adobe Reader) was to use a more conventional font, in my case Times Roman, to work around the issue.

LibreOffice Manuals are available online and also printed copies from Lulu. I am sure they would be able to help you. English documentation | LibreOffice Documentation - Your documentation for LibreOffice

File > Export As > Export as PDF

[X] Reduce Image Resolution 300 DPI
[X] Archive PDF/A [O] PDF/A-1b

There is a video here:

Still does not work for me.
Following in discussion : LibreOffice Writer export pdf does not embed fonts