Enabeling macro record in calc

hi, i am struggling to get macros to work in Calc. “tools/macros/record macros” is grayed out and can not be clicked, how do i enable this button or function. libreoffice


On Linux or Windows you have now to enable Tools Options LibreOffice Advanced Enable macro recording

Mac equivalent: LibreOffice Preferences


thank you, i tried that, but my tools drop down does not have “options” is there another way i can get to that dialog?

I updated my answer for Mac Users…

thank you, i found it

i do not have “advanced” under LibreOffice so I can’t reach enable macro recording
please advise


As I recall it had to be in Tools Options LibreOffice General.

Unless you do not have the choice of version, I advise you to upgrade to a newer version because the latter provide security fixes in addition to bug fixes and new features.


This is what worked for me (solution copied from another thread on this board):
LibreOffice → Preferences → LibreOffice → Advanced → Option: [x] Enable macro recording (may be limited)