Enter Abbreviation into cell

When I enter MGs into a cell, it then goes to Mgs.

How can I keep the capitalization?

There are four options really

  1. Immediately after Calc changes your entry, press Ctrl+Z (Undo) and your original entry will be restored. If you will only ever enter it once this is probably OK.
  2. For further use, after completing step 1, right-click on MGs and select Add to Dictionary or
  3. In Tools > AutoCorrect Options > Exceptions, under Words with TWo INitial CApitals or sMALL iNITIAL add MGs then press button New. or
  4. In Tools > AutoCorrect Options > Options, untick Correct TWo INitial CApitals. This is global though and might be excessive for a single instance.

Cheers, Al

Thank you, 3 worked. (did not get the “Add to Dictionary” with 2)

Ah. Probably I should have mentioned that you need to have Tools > Automatic Spell Check turned on for step 2 to work; I do. You could instead do a Spell check and add it then.