.eps images not shown in Impress [solved]


Dear users,
I’m a newby of LIbreOffice. I have some presentations with .eps files created under an older LibreOffice version (I cannot tell you which one: my laptop died while updating from Ubuntu15 to Ubuntu18.04 and the previous LibreOffice version was the one running under Ubuntu 15 LTS).
I’ve now installed LibreOffice 6.0.6. When I open the old presentations, where .eps files where embedded (not linked), I just see a rectangle and some writing (looks like the eps file name or something similar).
Also when I try to place a .eps file in a new presentation, I only see a rectangle. The weird thing is that in the preview, when opening LibreOffice and looking at the most recent files, I can see the figures, but they disappear when I open the file.
I’ve looked for the “Images and Charts” icon, but I cannot find it
Also I looked in Tools->Options->LibreOffice (and LibreOffice Impress)->View but I couldn’t see anything related to displaying figures.
Can you maybe help me?
Thank you very much

Cross posted and solved here

Thank you for your reply Robleyd!
I think I solved the problem by installing a missing library (libgs9-common) which was causing issues also to other platforms. Now I can see and add .eps images.