Epson printer problem

I have a friend who is new to Linux ( Mint 19.3 ) and Libreoffice 6.0.7,3. He has an Epson WF3540 series printer. This printer has 2 trays. He has envelopes loaded in one tray and A4 paper in the other. When he tries to print a document it keeps trying to print to the envelopes even though he selects the tray for letters.
Is this an LO problem or perhaps Cups? As we are in lockdown I cannot visit him and it’s difficult trying to diagnose the problem.

Probably a configuration issue. CUPS can manage tons of different printers. Has he selected the correct PPD (printer configuration file)? Does print act normally from other application, e.g. a simple text editor?

Okay so I got him to try printing something from the text editor and it worked correctly. So I am thinking it’s something wrong in LO. Now need to figure out what to check. Any ideas please?

Are there several printers configured on the Linux box? If so, is the correct one selected (stupid, I know, but make sure)? Does the driver keep default settings different from user’s choice? When print dialog opens, are settings the same as in the OS (or text editor)?

I got him to run some commands and email me the results.
He has 2 ppd files relating to his printer which is worrying;
I wondered what difference there is between them and asked him to send a copy of each one.
As they are owned by root he couldn’t attach them. So I have sent him instructions so he can but he hasn’t replied yet.

From what I see on my system, /etc/cups/ppd/ contains the printers which have been configured. The file name is the name given to the printer by the user when adding it. Then WF-3540 is not technically significant.

The original ppd’s are in /usr/share/cups/model/foomatic-db-ppds/ (Fedora path, may be different in Mint).

I’m using CUPS 2.3.3. Trying to add an Epson 3540, I can’t find the model. The nearest seems to be WorkForce 30 but i am not familiar with the Epson family. If the ppd was badly chosen, this could explain the problem.

Thanks for the information although it just shows that different distros do some things differently. It’s different on Mint compared to Fedora. The printer name is the name that cups finds and isn’t what I choose for it. There is nothing in /usr/share/cups/model/ on mine and I installed the same Mint on my friends. I’m using cups 2.2.27. So it seems to me that the 2 3540.ppd files are significant. Of course I will have to wait for him to send me the 2 files so I can look at their contents.

Solved. The 2 3540 ppd’s do relate to 2 copies of the printer installed. When he comes to printing anything both appear in his list so somehow he has got both set up.
I have solved the original problem as follows

Open a writer document.
Go to tools/options/Libre Office writer/print and take the tick out of the “Paper tray from printer settings”.
Now both of the installations work correctly.
I have told him to always pick the top one when he wants to print. I will leave it at that for a while and then talk him through removing the other printer in his list

This means the envelope tray is the default in the OS (CUPS) and also other apps ignore the OS setting to force their own. It would be interesting or safer to set another default in the OS.

The envelope tray is an adjustable tray and is the main tray on his printer. The other tray is described as the alternate tray. Now he has told LO not to use the Paper tray from Printer Settings it works fine. As your LO is different to ours it may have adverse effects on other apps if I try to alter things. The old adage “If it ain’t broke don’t fix it” comes to mind. :<)

Very sane adage to which I fully adhere.