Error 1303 when installing LibreOffice 4.0.2 on Windows 8 Pro

Hi there,

I am trying to update LibreOffice to the latest version 4.0.2 on my Windows 8 Pro 64-bit laptop.

I get so far, until I receive the following error:


Upon right clicking on the installer file, and seeing if I can run it in administrator privileges, I am unable to select that option. There is only one user account on my laptop - my account, which naturally is an administrator user.

Checking LibreOffice 4.0.3 Install error in Windows 7 x64 I tried following those instructions (replacing the file name LibreOffice_4.0.0_Win_x86.msi to LibreOffice_4.0.2_Win_x86.msi, but it resulted in the same error.

How do I go about installing this update?

Also, already stressed that it won’t update correctly I couldn’t even add the error image as an attachment (requiring 3 Karma points); resulting in further annoyance at having to upload to PhotoBucket etc. [And now the tags line wants text, and specific tags too. My word…]

Many thanks for any help,

@StevieTNZ – (1) Upvoted = 10 “karma points” to add comments to answers, and to upload images …

(2) Upload error message

This is bug FDO#58118. According to the MS support link in comment #3 the solution might be:

To prevent this error from occurring, make sure the folder location into which you are installing Office has Full Control permissions for either the Everyone group or the SYSTEM group. Check the permissions for the parent folders because the permissions on these folders may also cause this problem.

EDIT: I am adding in a couple of links that provide clearer step-by-step instructions for various versions of Windows as the MS instructions are terse. This problem is not a LO-specific issue, but a general OS directory permission error. The instructions provided for Adobe Creative Suite (XP and Vista - rename file from ODT to TXT extension) and Quickbooks (XP, Vista, 7, and 8) are hopefully detailed enough for less experienced users.

Thanks for that link. The information was utilised, and now the program has successfully installed. :slight_smile:

Having the same issue with Totally bonkers.

However, the most user-friendly solution is not to mess with the permissions (which may or may not work depending on the version of Windows 8 (the later the worse)) but to sidestep them. Mostly it seems like the anal-retentive approach applies to folders created by the system, so the solution I found was to tell the LO installer to install into a new folder (in my case C:\Programan\LibreOffice4) and it worked fine. You end up with an extra folder but you have two of them anyway (Programs and Programs (x86)) so what’s a third! Certainly beats messing with the instructions.

PS the link to Adobe is no longer working

Thanks. I have downloaded the original text (for Adobe instructions) and permanently attached it to the link in my answer.

Unfortunately that is an ODT file you attached, and since I am having this error I can not open that file - the old version of LibreOffice is already uninstalled.

Any chance of a plain ascii copy?

It is a text file but this site does not allow uploading of files with TXT extension. Just rename the file (as indicated) from ODT to TXT.

I believe this is a bug relating to the uninstall of the previous version of LO. I encountered this while running the installer with the previous version of LO open, at which point I was prompted to close LO. This resulted in the \program folder having invalid permissions. No admin account could view or change the permissions.
A reboot worked though. :slight_smile:

LO version 4.4.0
Windows7 x64

From what I hear from Windows programmers on this issue, it’s caused by not using the proper API calls (and/or using them in the wrong order) during the install.
The workaround which I found works is:

  1. Disable UAC (Control Panel=>User Accounts)
  2. Reboot
  3. Install LO (and optionally the help pack)
  4. Re-enable UAC at previous level.
  5. Reboot

And no, I did not feel comfortable doing it.

Alternatively, if the installer is an unmanageable tissue at this point (which could explain the reluctance to prod it it), you could look at

So my 2-cents on this issue which has really never been resolved, and I have invested about 6 hours searching and attempting all kinds of ideas suggested here and with MS. None of which are viable.

I have been using computers since 1990 and have never had this kind of an issue installing a program, nor with the Win 8.1 system on this PC.
It seems to me that the root issue is in the way LO wants to install, that seems to be somewhat unique, and not friendly with the Windows operating systems.
Deciding to stop all the struggle with this program, which has been touted as better than the Apache version, I have gone back to Apache. Reinstalling the Apache OO seems to have resolved the freezing issues I was having with it.
And interestingly a similar issue came up with shortcut installations …however, with Apache OO I could click through the errors and continue with the installation, sans the specific issues …and the program functions.
So, it is possible to not have these issues prevent an installation.
I suggest implementing the same kind of installation protocol for LO …and perhaps there is a way to have the shortcut options available later after the program is installed …maybe there would not be an issue with Windows Permissions.