Error 1303 when installing LO

1). I’ve been using LO 4 for some time. Today I was alerted to the arrival of LO So I downloaded the .msi file and tried to install. It failed (several times) giving error 1303 - requires admin privileges.

Mine is a single-user W10 PC. The only account is tagged as Administrator. Why did the installation fail?

2). I had no option but to back out of the installation, but I then found that the previous version of LO had also been uninstalled. I was hoping, as I gained confidence in LO, to reach the point when I could do without MS Office. Good job I have taken no such steps!

3). I had built a database using MS Access, and have exported the most important tables into Excel. I would like to create a LO Base building on these spreadsheets. Is it possible to populate a Base table from an Excel spreadsheet?

Your topic title shows “LO” I believe it should be LO “”
Anyway, hope you’re tried a more recent version.

For your item 3, please post it as another question to get better attention.

Prince is correct. Additionally, it is best to use the download link right from an LO application (like writer), so you don’t download the same thing twice.