Error loading BASIC of document file

Every time I open a file in LibreOffice, version 3.5.1, I get this message:
Error loading BASIC of document file: ///C:/Users/nylo/AppData/Roaming/LibreOffice/3/user/basic/dialog. xlc:General Error. General input/output error.

Dell tells me libre office is partly responsible for causing my 64-bit laptop to freeze.

I love LibreOffice. How do I fix this? I replaced an earlier version of LibreOffice with this latest version, but get the same error message. My friend who uses LibreOffice does not get this message. Please help. ML, Carolyn Berger

OP: @schatzi

LibreOffice 3.4.4 (Ubuntu version) shows the same message twice: one referring to ~/.libreoffice/3/user/basic/dialog.xlc and the other referring to dialog.xli in the same directory. I did not find such files, so I simply created an empty file named “dialog.xlc” (based on suggestion #2, accepted answer) and it seems to have eliminated the problem.

You might try as follows:

Close LibreOffice and Quickstarter (if enabled).

(1) Open dialog.xlc [path: …\3\user\basic\dialog.xlc] in a text editor and delete all invalid paths (mostly errors with installing/uninstalling extensions). Then save the file. Run LibreOffice …


(2) Open dialog.xlc [path: see above] in a text editor and delete all content. Then save the empty file. Run LibreOffice …


(3) Replace dialog.xlc from user profile [path: see above] with dialog.xlc from program directory [path: …\Program_Files\LibreOffice_3.5\presets\basic]. Run LibreOffice …


in OS X Lion, you’re likely doing:

cp /Applications/ ~/Library/Application\ Support/LibreOffice/3/user/basic/dialog.xlc

I too love Libre Office and have this error as well. I have tried all of the above including uninstalling and reinstalling the program all to no avail. Further help please?