Excel files open with text import filter

Some, not all excel files downloaded from a partner business web site will not open in Calc but attempts to load with a text import filter. Have tried default and various different options in the filter but all attempts to open the files results in a corrupted and unusable import.
We are using Libre Office on brand new Lenovo PCs running Win 7 Proffessional. Files are usually downloaded with IE 11 but have also downloaded using Firefox 26.0 with no difference.
Having done more research as we have slightly older installations that cope OK with these files, it would appear that LibreOffice works fine with these files, but version 4.1.4 will not work. I have now fixed our immediate problem by uninstalling 4.1.4 and replacing with 3.5.5 on the affected machines.
Note that 4.1.4 will open some excel files fine, even from the same partner business, but consistently fails with the same particular files from their web site.
I’m quite happy to upload one of the problematic files if there is somehere to do that. OK just tried but not enough Karma apparently
We would like to use the most up to date libre office but will not be able to do so until this is fixed or if someone can point us in the right direction for a fix. Thanks for any assistance. Paul

What file format are these “Excel” files actually in? Note that websites frequently disguise file content being Excel by just supplying the file extension .xls but the content may be Text, CSV or HTML. It might help if you could give an URL where to download such a file. Or file a bug at https://www.libreoffice.org/get-help/bug/ and attach a file.

Renaming my .xls file to .html and using Calc’s File → Open dialog worked for me when I ran into this problem. Thanks to previous commenter!