Excess space between last text line and first footnote in Writer.

When using footnotes in LO 7.0.5.2 (x64) build 64390860c6cd0aca4beafafcfd84613dd9dfb63a in Windows 10 Build 19042, on the pages prior to the last page, between the last line of text and the spacer above the first footnote on the page is enough vertical space for about 13 text lines. However, there is only one carriage-return line-feed below the last line of text and above the footnote spacer. The typical footnote is only one or two lines in length.

When printing or viewing the page, how may one reduce this vertical space to a negligible amount?

The document can be in .rtf, .odt, .docx, or .doc format. Pressing Down-Arrow moves the cursor from the CR-LF line, which is a blank line just below the last text line on the page, down to the first line of text on the next page.

Edit your question to give more information about your text formatting (main text, not footnote). Which is the paragraph style used? What are its properties (in case you changed them)?

In particular, have you widow/orphan management enabled? For which amount? Has the paragraph don’t split or keep with next property?

It is highly recommended to save your document in .odt. Any other format will cause conversion on read and save with cumulative errors across editing sessions.

ajlittoz, thank you for encouraging me to keep documents in the .odt format. I’ll plan to do that.

The Default Paragraph Style is as follows:

Automatic + Western text: Liberation Serif + 12 pt + English (USA) + Pair Kerning + CT L text: Liberation Serif + 12 pt + Align
left + Orphan control 2 Lines + Widow control 2 Lines + No hyphenation, Page End, 2 characters at end of line, 2 characters
at beginning of line, 0 hyphens + 0 + Text direction left-to~right (horizontal).

In Paragraph style, Text Flow tab, the following is seen:

"Do not split paragraph" is Greyed out,
"Keep with next paragraph is black and un-checked,
"Orphan control" is checked and set to 2 lines, and
"Widow control" is checked and set to 2 lines.

Un-checking both Orphan and Widow control options results in the 4 option being in black text. It shows the first page without any lines between the last line of text, which is mid-way through a paragraph, and the footnote spacer. So, your suggestion has corrected the first page. Thank you.

Now on to my next error. On the second page, in mid-paragraph, there is a page break at the end of a text line with CR-LF at the line end at the right margin. On this second page there is a space of about 6 lines above the footnote spacer. Placing the cursor on the last line to the right of the last character of the text and pressing Down-Arrow moves the cursor to the right end of the first line of text on the next page.

The third page is perfect – just like the first page. Thank you again.

The fourth and final page has only part of the page with text and a few footnotes. Consequently, there is a large white space between the last text line and the footnote spacer. This appears just fine.

Making the same formatting changes on an earlier iteration of the document gives perfect results for pages one and three. Only page two has the excessive vertical white space above the footnote spacer. Page four appears unchanged.

ajlittoz, thank you so much for your help. You have been quite effective. I am very pleased. Any more suggestions would also be much appreciated. Bruce

Mmmh! Sounds like you don’t use (paragraph) styles as you should. Default Paragraph Style is a very special style to assert default formatting rules common to all other styles. Changing anything here will apply to all others (unless overridden in an intermediate style) and likely mess up your layout. This is why it shouldn’t be used to format discourse text (for that, use Body Text).

For better diagnostic, attach your file to your question (for that, edit the question and use the paperclip tool – not available in a comment). If you think your content confidential, replace it with neutral text, e.g. type “lorem” (without quotes) and immediately F3. Make sure, it is styles like the original and the layout/styling/volume are similar.

PS: there is no CR-LF in Writer. You get a paragraph break when you press Enter and Writer handles this to start a new paragraph on a new line with some space between both paragraphs.

ajlittoz, you are really prompt. What a nice way to add lorem ipsum to a document. Thanks for the tip. Also, I did not realize that “You get a paragraph break when you press Enter.” Your implied substitution for CR-LF is exactly right. Thank you. Thank you.
I plan to learn how to use the paragraph styles as I should. Your help is wonderful. Bruce