Extra space between paragraphs

LO version
Using Windows 10 Home.
New to LO Writer. What am I doing wrong here? On a previous doc, I was getting extra space. I realize that header and footer area needs to be considered as non print area and margins need to take that are in account prior to printing (is this correct?), So, I created a new document and added the page numbers before I pasted the text into the new document. I’m new to OL and am trying to understand page styles, but it must not be clicking in my MS Word trained brain. What am I missing? Where am I erring?

I guess (because it wasn’t stated explicitly) that the problem is, that the text is limited to a couple of lines on a page, and then flows to the next page, even though there’s lots of space on the page, right? Attaching an ODT in addition to the screenshot would be best.

Yep, Mike, you are correct. I’ve messed around with styles, footer and header sizes, margin sizes, indents, page styles, but I’m not an IT guy with a company…so, I don’t even know what an ODT is. lol. I learned alot here. Thank you.

ODT refers to document file extension when it is saved on your computer, e.g. document.odt. This is LO Writer native format. A word document is saved as document.docx.

Your screenshot doesn’t show a lot: View>Formatting Marks was not enabled and the shot is missing the toolbar(s). We have then no idea about the applied style.

If the issue is a spurious page break, you may have “botched” a paragraph style by attaching a systematic break to it. Only analysis of a sample file can tell.

I suppose, it was enabled.

Oops! I suppose I shouldn’t connect to AskLO late at night.

As you are on Windows the extension of files is usually hidden by the caring OS to protect you from complicated things. You were asked to upload the file instead of a screenshot, so we can check your settings for page and footer.

There is a button for uploads, when you edit a comment here:

Not sure what the specific question is. Here are a few generic points about page styles.

A page style describe the general layout of a sequence of pages (those where the page style is applied). Whenever your layout is different, you need another page style. Page style effect ranges from one “boundary” to the next “boundary”. A boundary is either start/end of document or a “special” page break you Insert>More Breaks>Manual Break where you tell which style is applied after the break.

The layout defines margins which are strictly non-printing areas (this is different from M$ Word). All your text will go in the area between the margins. This text is made of header, footer and discourse.

From this definition, you understand that space needed by header and footer is borrowed from the available one between the margins. When you enable a header or footer, the height of the discourse area decreases (unless you modify the top and bottom margins).

Header and footer can contain a complete sub-document (repeated on each page). By this, I mean that all Writer possibilities are available: text, tables, images, … All these objects can fe styled and formatted just like you’d do in the main area.

Many features have different implementation (and behaviour) in Writer compared to their counterparts in Word. Using “muscle memory” in Writer will drive you into wrong and unexpected results. The most difficult when switching applications targeting the same purpose is to forget voluntarily what constitutes your routine and to accept with humility to start from scratch, e.g. by reading the Writer Guide.

Thank you. The question was (or should have been) “How to get rid of the gaps in a 300+ document without having to apply Page Styles to every page?” Since I added the page number to every page in only a couple of keystrokes, I was hoping for an “adjust one, adjust all” option that I’m sure is there, but need more experience to find it. Thank you for the prompt response and the redirect to the redirect to the WriterGuide.PDF. Very helpful.

What paragraph style is the body of the work in? Coming from Word, it might be Normal?

  1. Right click the style in the Styles pane of the sidebar and select Edit style
  2. Select the Text Flow tab and untick Keep with next paragraph. OK. The paragraphs should flow properly.

The setting Keep with next paragraph is used for Headings and table captions. It shouldn’t be used for the body of the text.