Fatal error opening xls file "osl: Thread create failed"


I am having trouble getting libre office Calc to open XLS files that are created on export from a website. I use a PC, Windows 7, Firefox browser.

I know that the export function is working correctly because others using it can open the Excel files in Excel itself. I also know, by opening the file with Notepad, that the coding seems okay (see below for header), and that all the information is there (21,000+ entries).

LO will open XLS and XLSX files created directly in Excel, because I have tried that.

It looks as if this problem has persisted for several years. I have looked around on various of your forums and tried several of the solutions proposed, but none of them work.

While I understand and appreciate that much of the work if not all, on LO, is voluntary, and in general it seems a fantastic alternative to MS, it’s a bit frustrating to read the rave reviews and then find that a key function isn’t working! I would appreciate some guidance – or a workaround that isn’t too time-consuming - because I downloaded LO specifically to open these exported tables, hoping LO would do better than Open Office, which truncated the files. So far OpenOffice is winning because at least it opens the file !


Exported Excel results
Exported Excel results

That is not an Excel file but a html file. Can you provide a sample of the real file? It may be that the Excel format version is old and cannot be opened. Or you may be downloading incorrectly if the downloaded file starts as above.

You say

others using it can open the Excel files in Excel itself

but that does not necessarily mean that it is an xls file. The coding you posted is from an XML file, not a .xls file.

You could try Apache Open Office from http://www.openoffice.org/ - it may handle the file better.

Please upload an example file with the problem or point to a website where it can be accessed.

Cross posted here which seems to provide an answer.