File Edit.... toolbar disappeared along with text formatting

I have lost the toolbars . Tried everything to get them back. Grateful for any help. Also autotext seems to be not accepting new entries. Using 5.4 and tried reinstalling newer version. OS is Windows 7

Thanks for the votes

You got enough points to upload your screenshot now…

Thanks - I have added a screenshot

The fact that is survived a new install points to a defective user profile.

If you press Alt does the menu appear? That’s a system setting in Windows, often used on laptops.

You can close LO, rename your LO user profile, and then open LO to create a new profile. See if that changes anything.

Hi thanks for trying to help. Alt button does nothing. I googled how to rename the user profile. It said to restart in safemode which didnt help and it said that therefore the userprofile was not the problem? I found the user folder on my laptop but not sure how to rename. Worried about losing autotexts too - I have a lot. They still woork but new ones cannot be added. causes a fatal error

I was unaware of that new Safe Mode method. My way of doing it is to rename the folder hierarchy, which is very simple and guaranteed effective. Whatever you do, take a backup of the profile so nothing will be lost in the experimenting.

AutoTexts should be located at .../libreoffice/4/user/autotext/mytexts.bau under your appdata\Roaming hierarchy.

These problems sound like a permissions conflict. Has the user profile been copied over from a different user or machine?

Hi. Ive made a back up. I wasn’t 100% sure what you meant by ‘rename the folder hierarchy’? I tried to rename the ‘user’ folder to alun, but it says the ‘action cannot be completed as the folder is open in another program’ Closed everything else down but still the same. btw the user profile hasn’t been copied over from another machine. Although this laptop is a refurbished second hand one. Would uninstalling help? I tried to do that before but no response when I clicked uninstall. Thanks again

I assume that LO’s new method of checking the profile is sound. But if you want to double-check (I would), in Windows Explorer go to your user folder, then appdata\roaming\libreoffice. Rename that folder to libreoffice-mine. Do this with LO closed and the quick start closed. You can call up Task Manager by right-clicking the taskbar and kill anything LO. When you reopen LO it will create a new user folder with correct permissions.

Hi. Closed all LO applications in task manager. Renamed as described. Opened a file but no menus at all on top now on top now. A sidebar has appeared with styles,properties,page etc
In the Roaming folder a new LO folder appears each time I open the propgram.

Yes, it will create a new folder if none exists. If it’s creating multiple folders that is a problem.

To get back to where you were, delete the new folder and return your profile back to its original name.

Is any other program acting up? This may be corruption of the Windows User profile. Once you’re back to Square One, you can copy the LO profile to a USB stick, create and log into a new Windows user, paste back the LO profile into its appdata, and retry LO.

Hi. In the end I tried reinstalling. It did work this time as I closed down the stuff in task manager that was still running. The toolbars came back which is great. I saved the autotext so I can sort that. However now when I go to open a file it says ‘The requested operation requires elevation’. Tried chamnging the permissions but they were mostly OK anyway. And I can open the files with Open office. I will try and find permissions in LO. Any further advice gratefully received.

OO opens the same docs LO doesn’t? That confirms there is a permissions problem, but now it seems to be with the executable rather than the profile. Do the permissions of the LO folder under c:\program files line up with those of other nearby folders? Also check the one at c:\program data, I think it is. If there’s a problem, maybe a complete uninstall, and deleting those two folders before reinstalling would be in order.

OO opens the files no problem. The permissions of the LO folder are all now Full Control but still get the Elevation message. Previously I did a complete uninstall and got the toolbars back. I can open files that are in the recently opened section, but they appear without toolbars! However double clicking an old file gets the Elevation message. Appreciate your time on this

It’s clearly a permissions issue, the question is where it lies. I would do a chkdsk /f on the C drive to check the file system, which is where permissions are stored. You might need to schedule it for the next boot.

If that doesn’t do it, I would go back to my previous suggestion. Go to control panel / users and create a new user. Boot into it, and test from there. My best guess at this point is the user account is corrupted and that is causing the permissions problems.

Thanks. Will give it a try.