File extensions

When creating a new file or using “Save as” to save a file in a different format, file extensions are not included at part of the file name. These should be added by default. Why are they not included? Should I post this as a bug? Every other application I use adds the appropriate extension.

Hello,
File extension is included based upon the selection in lower right corner of save/save as screen:

Screenshot at 2022-02-28 20-52-38
.
or
.
Screenshot at 2022-02-28 20-58-23
.
etc.

Your question looks highly dependent on your OS and window manager. It is very different e.g. on Windows, Gnome, KDE. I recall some similar issue, where it was stated that this is what a specific Linux environment does, and it fits its HIG as it should. So you need to be very specific about relevant details.

tdf#121418
tdf#111070 (and tdf#111201, tdf#93199)
tdf#111071

OKAY, here is more detail. OS is Kubuntu. File manager is Dolphin.
Step by step to duplicate problem:

Right click on folder in Dolphin (Note: Creating new file in LibreOffice has same result.)

Click on “Create new”, scroll down to click on LibreOffice Calc
Box pops up and I type “New Calc” for a file name.
The file is created with no extension. I assume the format is the native .ods format.
I want to send this file to my friend who uses Windows Office.
Click on “File” then “Save As”

In the “Filter” box I select “Excel 2007–365 (.xlsx)”
“New Calc” is in the “Name” box with no extension.
Click “Save” and gives me the message the file already exists.
Click “Overwrite”
Close the APP
In Dophin, double-click “New Calc” and it does not recognize what application to use. File associations don’t do well without extension. Clicking on “Open with” LibreOffice

LibreOffice should automatically add the file extension by default.

BTW, there is a box in the lower left corner that says something about filename extensions that doesn’t seem to do anything.

1 Like

So it looks like several issues here at once.

  1. You used some OS means of creation of the document initially - using Dolphin (even though you wrote “Note: Creating new file in LibreOffice has same result”, it is not the same thing; and what Dolphin does is not necessarily what LibreOffice does. However, if Dolphin does not add extensions by default, it means to me that it’s what your OS/environment thinks is best; and then LibreOffice following that is the proper behavior, since applications should follow the environment-specific rules).
  2. You saved as, and that possibly exhibited tdf#111071 (or maybe not, since that was filed for Windows).

But please file a bug report if you think something is wrong; here is a wrong place for that anyway.

1 Like

I don’t know if this is exactly what you want, however, if you are using Windows 10, to see files extensions you need some steps.
.
Open File Explorer > Maximized the window > Select the Tab View > mark the checkbox files names extensions .

If this answer helps you, please, mark the :white_check_mark: as a Solution.

1 Like