'File' has turned into a list of objects on toolbar!

Where has the real ‘File’ on the toolbar gone? The list is of Character, Draw functions, Bold etc
I have version Use Windows 10 on a Lenovo laptop.
I wanted to turn a document into a pdf - which is an option in the real ‘File’ on the toolbar.

Have you changed the “standard” UI for some other tabbed one? If you can’t tell, edit your question to attach a screenshot.
EDIT: attach a screenshot so that we can have a visual idea of what’s going on.

1 Like

I haven’t knowingly changed anything, certainly not the UI which is as it has always been.

[[EDIT] Re-reading your question, if the contents of the File menu has changed then it is probably a corruption of the user profile, see LibreOffice user profile - The Document Foundation Wiki. Try opening in Safe Mode (Help > Restart in Safe Mode) and seeing if File menu is OK.

The UI can’t be the same because File menu is missing. Please attach a screenshot.


Right-click on a toolbar and select Customise toolbar. In the dialogue that opens, in the left-hand pane Available commands select Menubar. In the right-hand pane Assigned commands click on the words of the top command (if the tick changes return it to its original setting). Click the right-pointing arrow in the middle between the two panes to add the Menubar icon to the Assigned Commands. OK.

Click the new Menubar icon to toggle visibility of the menu

Thank you for your reply. I have tried the things you suggest.

  1. Right click on toolbar doesn’t do anything.
  2. I am unable to take screenshot as I have to right click to get that menu and that makes the ‘file’ menu disappear.
  3. The safe mode seemed promising - in Safe Mode the File menu was normal but after resetting the top two options nothing changed in the document. Libre Office itself has its normal (abbreviated) menu, but if I try to create a new writer document the File menu is changed as before (to contents of toolbar).
    I think the problem may have started at the last but one Update. (November - to 7.1.2) I don’t use the File menu very often so it could have become corrupted earlier.

Can you take a photo and upload it?

It wouldn’t add any useful information. Instead of the File menu, there is a vertical list beginning: Bold, Character, Draw functions, each with its icon. Some of these are on my toolbar, others are not. They are in alphabetical order.

You have tried Safe Mode (as suggested by @EarnestAl), and it worked. Now, restart in Safe Mode again, and check Reset to factory settings.

We (the other three that wrote here) are asking for an image. Why do you think it wouldn’t be useful?

1 Like

Partly, I’m afraid, because I don’t have a smart phone and getting a picture into the computer is a huge hassle. But also: you know what a menu looks like and I’ve told you the contents - what would an actual image add? It is in glorious technicolour . . .

I didn’t want to reset because I feared I would have to get LO as I need it all over again and I don’t have the time at present. (Deadline.) Is it correct that I would have to customize from scratch again? If so, I will have to leave it as it is until the Easter holidays.

The reason why we want to see your screen is because there seems to be a misunderstanding about words we and I use. We aren’t sure your description address the menu or some other dialog. Also depending on the installation defaults, you may have got unknowingly some fancy UI.
Customising from scratch doesn’t seem a requirement for me but it depends on the extent of your present changes. So, once again, show us what it looks really like.

You can make a backup of your user profile. But I never restored an user profile, just restarted in a clean one, so I can’t help you so much answering this.

(Excuse me that, altough my UI language is in English, the screenshot is in Spanish)

Another option (so you can continue with your proyect in the actual installation): Enter in Safe mode just to export as PDF.

A third option: Make a parallel installation, so you can choose in which one to work. And once the deadline is over, you can reset the user profile and recustomize LibreOffice.

Before you reset your user profile, please try suggestion 1. below. Cheers, Al.

You probably have the Tabbed interface which does not accept right-click. To toggle visibility of the menus, click on the extreme left icon with the tooltip Menubar, see image

To take a screenshot press the PrtScr button on your keyboard (top row after F12) then paste the clipboard into a graphics program, or even Writer. This is a Windows function and it will capture the open File menu.

Thank you! PrtSc works! (It didn’t on my old laptop so I didn’t try it). My toolbar doesn’t have the icon your arrow is pointing to. It isn’t available in the list of Tools either.

So here it is.

Apparently you’re in “Standard Toolbar” mode and the File menu is badly damaged. It looks as if it is a duplicate of the toolbar. Are you sure you didn’t right-click on the toolbar while taking the screenshot?
Other than that, I can’t identify the kind of toolbar shown. Have you already customised your toolbar?

Thank you for your help. I don’t need a functioning File menu for the work I’m doing so I will keep all the advice for the Easter holidays when I should have more time.

Thank you for your reply. See screenshot if still interested!

Thank you. I have managed a screenshot now!

1 Like

For the screenshot you shared (thanks for it), I am assuming the File menu was customized from scratch.

To see New, Open, Close, Save, Save As…, Export…, etc. again, you can reset the File menu, something you don’t want to do now. But in the meantime…

You can add the command Export as PDF… there:

  • choose menu Tools - Customize… - Menus tab,
  • in the Search field type “PDF”
  • in the Available Commands field choose the PDF command with the tooltip containing .uno:ExportToPDF
  • in the Target field choose File (maybe just it is there)
  • click on the button with a black arrow pointing right (Add item)

You can change the position of the command:

  • in the Assigned Commands field, deselect then re-select the Export as PDF… that was just added (maybe there is a bug here, note that the up and down arrow buttons are greyed out until re-select)
  • click on the up and down arrows to the right of this field, until reach the desires position
  • OK

Yes, I have customized toolbar. But I haven’t touched the File menu. That happened all by itself.