File name changed by libre office writer when I save, close, and open again

Writer is set to save all documents as .docx I save a new document and name it, for instance,
I work on it, save, close, open, and although file explorer says it still has the original name, Libre Office says it is now named something like MO90CE~1.DOC
That name shows at the top left corner, and in the list of recent documents.
If I email the file, it goes as the short name above, assigned by Libre Office.
This began just recently. I have done nothing different that I am aware of. I tried reinstalling Libre Office. I reset to factory settings. I reset file explorer.
Any ideas how to fix?

I assume you work with some Windows. You may have “found” one of the old compatibility layers wich eindows provides for older software. In this case this ensures old software wich never expected any filenames to be longer than 8+3 characters allowed by MS-DOS to access every file with longer filenames.
Windows therefore generates short names for files and folders and ensures uniqueness. Usually newer software does not get this kind of treatment, but maybe MS changed something on last patchday…

I found it! The name of the folder was too long, and nothing told me that. When I changed that, Libre Office stopped re-naming the files.
Thank you!

AGAIN: LibreOffice does not rename anything. Create a money-cure-9-2022-clean_ch18_Sylvia-returns_peer.txt with the Windows text editor or some money-cure-9-2022-clean_ch18_Sylvia-returns_peer.bmp with the picture tool and the result will be the same.

Windows has/had 260 character limit for path and file name. 32 bit Windows has this limit always but apparently you can change it for Windows 10 64bit, see

I think you are correct, and will add your response to my info about solving the problem.
I created a new folder with a short name, copied the text from each file, pasted into a new document, gave the.docx file a short name that still allows me to recognize the file, and that seems to have worked.
Thanks for your help.

Another option is to use “old” SUBST-command to assign a short drive-letter like X: to your parent folder and use X:filename to access files…

Which version of LO are you using? I suppose there might be a regression, if your version is 7.4.

E.g., there is tdf#151117; your case might be similar (but a bit different - maybe your directory was not that long, and a different code path broke).