files won't open in windows 10

Since upgrading to Windows 10 I cannot open any ODS or ODT files. Every time I try to open a file in LibreOffice it just hangs indefinitely. Other files will open in LibreOffice.

I’ve also updated LibreOffice to v5 but I’m having exactly the same problem.

I’ve checked file associations in Windows 10 and that seems to be set up properly so I’m at a loss to understand what is going on.

[Edit:- added windows-10+ lo-5 tags]

My LibreOffice Writer has been working fine since I upgraded to Windows 10 a couple months ago.

However, just now, it won’t open a new Writer doc or any of my saved Writer .docs. I looked under ‘properties’, but it all seems to be normal.

I’m guessing this has something to do with a dodgy Microsoft update suddenly messing everything up, but I have no idea what to do. Other people seem able to open their docs as ‘read only’ - I can’t even do that.

I cannot open documents in Writer or Calc. I would blame a Win 10 update BUT two out of three machines work fine [Acer Laptop: LO v, Windows 10 Home, 64-bit version 1511, 10586) and Samsung Netbook: LO v4.4.5.2 Windows10 Home 32-bit Version 1511 (OS Build 10586.36)]. My Chillblast PC opens LO and invites me to ‘Use the sidebar to open or create a file’ then I just get a spinner… [LibreOffice v5.0.4.2 Windows 10 Pro 64-bit, Version 1511 (OS Build 10586.36)]. Suggestions, pretty-please?

Next day: BOTH Open Office and LibreOffice (which did NOT work when I complained) DO WORK. I am delighted but mystified. Winver gives Win 10 Version 1511 (OS Build 10586.86) and LO gives v which is the same as when the thing would just spin aimlessly. Sorry for wasting your time but it is information on what can happen I guess.

“Next day”? You mean you have waited 6 months to tell us this? Oh! hold on, you are not the OP. You want a suggestion:- start your own question.

I may have solved this using advice from the OpenOffice forum…

In the Windows 10 search bar type %appdata% and Enter. File Explorer should open and you should see an LibreOffice folder. This folder contains the user profile. Rename the LibreOffice folder (in my case I just renamed it to my Windows User Name).

this did not work out for me, i have renamed the “user” folder to “user-old” started LibreOffice a new folder “user” was created, but still when i open any document hang indefinitely.

There are now at least two other identical questions for this problem:-

  1. Q55755
  2. Q55838

So, well done to Prolink for confirming that Restoring a default Profile is the way to fix this. Just one note:- the 5.x Profile has an identical location to the 4.x Profile folder.

2015-09-09 Update:

Prolink: “I’ve tried … (deleting, + ) restoring the default profile … Deleting .~lock files in the same file location … one thing I didn’t mention was that I use Dropbox to store files”

That after-thought mention of Dropbox is likely to be a key factor. Investigating it shows that yes, it has the precise method of working which is guaranteed to shaft LO/OO:


Dropbox is a home for all your photos, docs, videos, and files. Anything you add to Dropbox will automatically show up on all your computers, phones and even the Dropbox website — so you can access your stuff from anywhere.

How does the Dropbox service work?

(here is the key phrase):- “…, and update linked devices when files are added, changed, or deleted.”

In brief, here is how LO/OO works, with emphasis upon how the use of Cloud storage such as Dropbox will inevitably cause problems:-

  1. LO maintains a user profile + a system profile.
  1. At program startup lockfiles are placed into both locations.
    (the system profile lockfile is for the program startup
    (the user profile lockfile is for each document opened)
  2. LO/OO is NOT multi-user
    (the lockfiles are there to ensure that no other user/process can open or change the document)
  3. At document close the doc lockfiles are removed
  4. At program shutdown the program lockfile is removed
  5. At next startup, if either lockfile is discovered, then the startup is stopped & an error message is issued.

Thus, the Dropfile service needs to be placed into suspension whilst LO/OO is active, or whatever Dropbox advises as the correct working method to prevent it from activating LO’s lock-checks. In particular, be careful to check that:-

  1. Dropbox is not copying either lockfile back into the Profile folders/directories after LO has removed it
  1. The Dropbox access does not lockout LO from being able to access it’s own files
    (this was my constant experience with XP whilst using rsync - fantastically annoying)

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

It turns out I haven’t resolved this afterall. I continue to experience indefinite hanging when I try to open an ODS file, yet it works perfectly well with XLS files.

As well as restoring the default profile I’ve tried:

  1. Upgrading to latest version (
  2. Deleting .~lock files in the same file location

…with no joy.

Not sure where to go next but one thing I didn’t mention was that I use Dropbox to store files. However, I tried opening one locally and the same problem persists.

I’ve discovered that if I open files in Excel Online (which is included free with Dropbox) I can save the document either as XLS or ODS and it will then open in LO. Not ideal but at least it’s a work around for now.