Find behaving strangely in calc


For some reason I am having trouble searching in calc. I will search for a particular keyword and it will pick cells that don’t seem to have anything to do with said keyword (and may or may not eventually find the correct cell). I tried updating Libreoffice (turns out I was a few versions behind) and even saving the spreadsheet in another format (xlsx and even csv, which removed my plots), but the results are still the same. It’s using some kind of logic–it matches the same cells every time to the keyword–but I can’t for the life of me figure out why it picks the cells it does or why it often ignores the correct answer entirely.

The spreadsheet has grown over time. I’m not sure when exactly the problem started. Perhaps it is because I upgraded to windows 10?

I appreciate your help!

Update with more details:

I’m using version
I’m using the find tool bar that shows up at the bottom when you type Ctrl+f.
For example, if I search the word: help

It will find several correct cells with the word help such as a cell containing: The Help

But it also says picks some other cells, like the ones following:
Challenger Deep
Half of a Yellow Sun

Another example, if I search: queen

I get the correct result:
Elizabeth the Queen

But also:

Please give relevant information.
Version of LibO? Example for your formulas, example for a wrongly found (accepted) cell content? Did you actually use the FIND() function or the SEARCH() function?

Searching cells how? Using the Find&Replace dialog? One of the VLOOKUP, HLOOKUP, MATCH functions? Please be specific.

Hello @tracya,

Please check your Find & Replace Options as follows:

  1. Choose the menu "Edit : Find & Replace ... ";
  2. In the dialog box that appears, expand the small triangle next to "Other options";
  3. In the “Other options” section, please make sure that the checkbox "Similarity search" is unchecked.

Hope it helps, lib

@librebel: The OQ clarified that he talked of the ‘Find Toolbar’ but not of the ‘F & R’ tool dialog.
In what way should the ‘Find Bar’ be affected by the settings in the ‘F & R’ dialog?
I actually do not know how to understand the described behaviour. User profile corruption?

Thank you everyone for your help!! I agree with @Lupp, that having the Find Bar be affected by the F&R dialog is unexpected, but @librebel, you were totally right! When I opened the F&R dialog, the similarity box was checked. Unchecking the box fixed my problem. I have no idea how that box got checked, but I’m so glad it’s fixed. I usually consider myself reasonably computer literate, but this behavior utterly baffled me. Thank you again for your help!

Glad it worked @tracya :slight_smile:

@Lupp, i guess that both the Find Bar and the Find&Replace Dialog share some settings, but that the Find Bar only has a UI control for some of these settings.