Finding entries in Calc with apostrophes

I use Calc to store my DVD/BD collection.

My problem: If there is an apostrophe in the title, i.e., “at sword’s point” it will not locate any of the words in that entry.

But if I enter it as, “at swords point” it will find it.

Edit 2018-10-09: Thanks for bringing that to my attention Mike. I am using and I just noticed that the latest version available is 6.1.2. I was just so frustrated, I overlooked the obvious.

I’ll download it and give an update tomorrow.

Edit 2018-10-10: After posting my problem, I have updated to LO (x64) and I am still experiencing the same bug.

I am using LO Calc as a database for my DVD/BD collection. Whenever a title has a word with an apostrophe in the title, i.e., “at sword’s point”, Calc’s response is, "search key not found.

However, if I change the title to, “at swords point”, Calc will find it.

Works for me with… what LO version are you using?

what is “it”? (in “it will not locate …”

Since I posted this problem, I have now upgraded to version

I am still experiencing the same problem.

If i forget to change “sword’s point” to “swords point” I can search for all the words after the word with the apostrophe, i.e., I’d search for “point”. This will only work if there is at least 1 word after the word with the apostrophe.

If the last word in the title has the apostrophe, I’m out of luck. Calc will not find anything.

Here’s how I get around this problem: I double list the title. The first entry doesn’t have the apostrophe, and the type point is set a 5 (to make it tiny compared to the main entry listed below it):

Running Wild (1927)
67 Mins Rtg NR BD BW FF

At swords point
At Sword’s Point (1952)
81 Mins Rtg NR DVD-R C FF

Phantom Tollbooth, The (1969)
89 Mins Rtg G DVD C WS

and here’s another example, same as above:

And so it goes (2014)
93 Mins Rtg PG-13 BD C WS

Ill see you in my dreams
I’ll see you in my dreams (2015)
92 Mins Rtg PG-13 BD C WS

Gods not dead a light in darkness
God’s not dead A light in darkness (2018)
105 Mins Rtg PG BD C WS

Book Club (2018)
103 Mins Rtg PG-13 BD C WS

Oh, and there are over 9177 entries in my DB = 9177 cells/rows.

You know that you are using a typographical apostrophe, U+2019, in your content not a keyboard apostrophe (U+0027)? I guess if you copy the bolded word Sword’s and paste it into the search, you will find it in your list. (If you click directly after an apostrophe and press the keys Alt+X, it will convert it to a U-number, Alt+X again to turn it back.)

You can stop LO turning your apostrophes into typographical ones by clicking on Tools > AutoCorrect Options..., in the window that opens click on the Localised Options tab and untick the Single Quotes Replace box (and the Double Quotes Replace box if wanted).

Also check that your Grammar checker if you have one doesn’t put them back again Tools > Options > Language Settings > English Sentence Checking and untick Quotation Marks. If you don’t have English Sentence Checking then don’t worry, probably.

You can find and replace all your apostrophes by copying the typographical quote into Find and entering a keyboard quote into Replace. You might want to do it field by field if you want to also delete your workaround text. Cheers, Al