Firebird option missing for new database

Libreoffice Version: (x64)
Hi, Today I wanted to start a new database using Firebird but that option was not available. Could someone please let me know what is wrong, why has this happened.

Thank you, that was the problem.


Comments should be placed under the section responding to.

Also, as you have been helped, please help others to know the question has been answered by clicking on the :heavy_check_mark: in upper left area of answer which satisfied the question.


This appears to be a bug. You can get the selection back. From the menu Tools->Options. Then under LibreOffice->Advanced enable (place check mark in box) Enable experimental features. Then close all open LO instances.

Firebird selection should become available again.

Thank you. that was the problem.

Thanks @Ratslinger for the heads-up.

I did not know that Firebird was now experimental. Updating LO, I must have failed to re-enable experimental features, and I was shocked to find Databases unable to run. No warning, just dead, which was alarming.

Not 5 years ago, I put great effort into converting databases to Firebird. I am worried now that Firebird is going to be deprecated, which would cause me grief.

What is the future for Firebird?

May I ask why?

Because I understood at that time that Firebird was becoming the default. It has worked fine for me with a couple of work-arounds.

There are many (little) bugs reported special for Firebird. HSQLDB will work much better together with the GUI. And: There is no Person, who will fix the special Firebird bugs to get it better. So we had decided for LO 6.4.3: Let us put it back to experimental for new Firebird databases.

If you are already using Firebird there will be no problem to use it also in future. It won’t be set to deprecated.

When it became default and tried to convert my HSQL, I let it convert 40 embedded HSQL databases with very discouraging results. I could convert dozends of embedded HSQLDBs to full featured external ones without problems. I also converted a non-trivial HSQLDB to Maria DB (aka MySQL) and all the forms, reports and parsed queries worked fine. Any database seems to do better than than the new default. I just don’t get the reason why it had to be Firebird.

Thanks, @RobertG . I find that the latest LO will not run my DB even when experimental features are enabled. 7.1.4 appimage still works. Has anything else changed?

My DB’s were all non-embedded, which I wanted to fix to make them more transportable. The switch to Firebird was certainly not trivial. All but the simplest queries needed to be modified. I cannot say that LO has handled this very well. But as is frequently pointed out, there is a lack of developers, and I am not in that league, so I can’t complain.

I also found LO7.2 to be problematic with earlier LO(embededFB) .odb.
previous versions of LO indeed do seem ok.
also Firebird4 and Firebird3 created .fbd are not it seems directly interchangeable (something about disc structures…)

Have just opened a Firebird database with LO on OpenSUSE. No problems here. But it might be it is bug 144163. Varchar fields in Firebird, defined for 20 characters, could be filled with more than 20 characters in LO 7.1 and earlier versions. This is a buggy behavior. Nobody knows how this has been changed for LO 7.2.2, but you can’t open such a table filled with more characters than defined in LO 7.2.2

UTF-8 is a special problem for the internal Firebird construction at his moment. A simple count of characters does only work with ASCII-characters, not with special characters.

Internal Firebird database is version 3. So it doesn’t support version 4. See bug 144619. Version of Firebird has been 2.5 when starting to integrate Firebird into LO.
Note: Internal HSQLDB is version 1.8 and will never been changed, because users will never run in the situation: Database could only be used in newer versions.

1 Like

This need not be turned on unless creating an embedded Firebird Base file. Existing Base files with this off work fine for me through TDF LO v7.2.2.2

One of the main reasons to change to Firebird was to avoid Java dependencies in LibreOffice.
If I’m not wrong, the issues using the embedded Firebird, are not from Firebird but from base to manage it.
In my experience, Firebird is like a rock and mature database, a project with similarities with LibreOffice.
Firebird as external database is at least as good as any other, their server is very reliable with a low weight using the Os resources.
The problem it’s find devs for base, If I remember fine the last year had a TDF’s tender to fix the bugs and get to finish the implementation of Firebird, that was not covered.
So this issue it’s also about to break the use of Jave in base, achieve improvements and a better integration inside the suite.

There is nothing wrong with Java. I run a little HSQL server since 11 years with zero problems (6 users, 400 records per week). Base was tailored around HSQL and works very well with H2, MySQL and PostgreSQL. After all those years, it fails to work smoothly with Firebird. When FB became the new default and LO started to convert HSQL to FB, I let it convert ~40 non-trivial database documents with embedded HSQL. Not a single one worked.

I am sorry @Villeroy, but there is much wrong with Java, WRT security.

LibreOffic is not a browser plugin.