Firebird_sdbc error


I migrate my LO to version 6.1 and when I try to open my database I get this error:~

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -206
*Column unknown
*At line 1, column 56
caused by

And can not access to my data. How can I overcome this?

Thank you for your time and help, regards


Your details are quite hazy. Based upon the error presented, you are getting this when trying to open a Form and not the database itself. If so, this form then contains a sub form and that is where the problem actually occurs. This is a known bug. See - Bug 117053. Comment #15 contains a macro to fix or you can change the file in the .odb directly using comment #11 instructions.

If this is not what is happening to you, you must present more information - What OS; migrate from what version; what is meant by ‘open my database’; can you access tables directly and see data?

Again thank you!
The problem is solved with your help. I used the macro and the forms work fine.
Your help was very appreciated.
7Kind regards

I am receiving this error as well. I cannot seem to edit the file directly per comment #11 or figure out how to run a macro per comment #15. Will this bug be fixed eventually or are these my only two options?

@sdrichey I am sure this will be fixed eventually but there is no indication in the bug filed as to when. This is a fairly simple fix. If you are having problems, please post as a new question and you should get help with it.

Thanks Ratslinger. Any idea why the bug is marked as VERIFIED FIXED, when it is clearly not fixed?

Well, from re-reading, it appears the problem does not occur when creating new Firebird Base files. Since there is the two methods of fixing in the bug report, that may be the resolution. For an absolute answer, you would need to ask there.

I can help with a solution immediately if you post a new question.

Ok will do, thank you.

Thank you for your answer. You are right: I’m trying to open a Form with subforms and yes I can open the tables.
I’ll read Bug 177053 and try to fix this problem.

Thank you for your time.

@evarejao Please use add a comment for responding. Answers are for responding to original question.