Font will not conform to style

I have styles set up to use Liberation fonts in a document. My default fonts are set to Liberation fonts.
I import some plain text from an email. The text comes up using Arial. Clearing direct formatting for the text only makes it worse - it changes to Arial bold. Changing to other paragraph styles does not alter the font. The only way I can get the correct font is by using character settings. If I then change the paragraph style it reverts to Arial bold. If I examine the paragraph style it is Liberation Sans regular.
The document is divided into sections and in the other sections fonts and paragraph styles are working normally.
How can I stop this font coming up?

LibreOffice on Debian testing.

If you are copying that text from the email, try pasting it as “unformatted text”: Ctrl Shift Alt V. If your email program have HTML formatting enabled (and most email clients do that by default) it’s quite likely that on a normal copy&paste operation Writer also “imports” some kind of style, hence the mess with formatting.

Ctrl Shift Alt V is what I normally do. I avoid HTML emails like the plague and have my email client (Thunderbird) set to text only.
Rechecking, if I paste the text into the document where the font has by manually reset to the paragraph font, i.e. Liberation Sans, it pasts correctly. If I then clear direct formatting for the text it changes to Arial bold.

Then, the problem is on the document. Could you upload a sample file to see what’s going on?

OK, it may take a day or two as the document I am working on is confidential and I will need to prepare a test document.