Font works in LibreOffice 4 but not 5


I would like to use the Jazz LET font. It is in the dropdown list of fonts in Writer in LO, but when I type, empty rectangles appear in the document where the characters should be.

I am running OS X Sierra. Jazz LET works correctly in LibreOffice 4, FontViewer and Notepad.

I have tried creating a document in LibreOffice 4 which uses Jazz LET and then reading it into LibreOffice - still blank rectangles. I tried LibreOffice 5.3.7 and that didn’t work either.

Jazz LET which is an old font in a Font Suitcase. Looking around on my machine, I see there are two versions. One is in /Library/Fonts. The second is in /Applications/Appleworks (International English)//Appleworks Extra Fonts/ITC Fonts.

Another font which is a Font Suitcase that works OK in LO5 is Handwriting - Dakota. It only appears in /Library/Fonts.

Any advice?

Thank you

What kind of font is “Jazz LET”? You need TrueType or OpenType in LibreOffice 5.4.

That’s useful to know. Because it’s in a Font Suitcase, I can’t immediately tell what kind of font it is. However, looking at the free downloadable versions, they’re all TrueType, so I guess it is too.

I suspect it’s got corrupted somehow. My easiest solution is to download a free font and just install that.

Thanks for your help