Fonts displaying poorly in LibreOffice 3.4.5 on Windows XP


On my laptop, some fonts like the “DejaVu” family displays very poorly in LibreOffice 3.4.5 (OS = Windows XP Pro).

They are like “pixelized” with the “pixel” size ~ 0.5 mm.
Of course the true pixels are much smaller.

I checked that the DejaVu fonts are present in C:\Windows\Fonts

On another laptop the same fonts display correctly and I cannot remember if I had done something special for this. What I can see is that the same fonts display very well in another software (Scribus).

What should I do so that all fonts display well in LibreOffice and not only the half ?


N.B. With an administrator account, I tried to remove the problematic fonts in C:\Windows\Fonts and to replace them by Copy-Paste with those from the other computer. But when I paste the TTF fonts, the OS informs that the fonts are already installed and should be desinstalled first.

Try enabling or disabling ClearType.

Thank you very much. It solved the problem. I had completely forgotten it.

For other interested: to activate ClearType, select Start → Settings/Parameters → Control panel → Display → Appearance (4th tab) → Effects… (button) → Check the 2nd checkbox and select “ClearType” in the droplist

The DejaVu fonts still do not display perfectly, but much better however.
Then, it’s also a matter of screen quality and the fonts display better on my other laptop which has an SXGA screen.

As the “DejaVu Sans Light” is very thin, I would recommand to select a relatively bold version if using afterwards Microsoft’s “ClearType Tuner”, which is an online tool to optimize the rendering by ClearType on your LCD screen.

Thank you very much. I had forgotten it and it really improved things a lot.

DejaVu fonts still display poorly, but much better however.

It’s also a matter of screen resolution and quality.
Fonts display much better on my other LCD screen which is SXGA and has higher resolution.