Fonts missing in Linux (though available to other software)

After a complete reinstall and upgrade of Ubuntu (to LTS 18.04, Linux 4.15) I’ve tried to recover all the previously installed fonts. No problem at all until I’ve tried to recover Vollkorn family. At first no one of them downloaded from Vollkorn Font Family · 1001 Fonts appeared on my LibreOffice Writer After lots of tries, automatically installing them with the GNOME Font Manager and manually copying to the various fonts related paths both for the user and for the system, I only got “Vollkorn”, “Vollkorn Medium” and “Vollkorn Semibold” to appear on the drop-down font menu at Writer or Calc.

All other Linux applications (Gimp, etc.) seem to get them without a problem. I even tried to install some older versions from the official author site: …and no way.

I’ve done all recommended things: update font system cache, closing and opening again LibreOffice, restart session, reboot computer… and no matter what I do, all other font sizes of this family are missing. We MUST work with one of them (Vollkorn Bold) but it’s still missing from LibreOffice.

I even uninstalled GNOME font manager because after so many tries it seemed to get frozen anytime I opened it. Maybe there’s some corrupted installation or something related to these font files???

Thanks in advance to anyone who can give us some clue on this frustrating problem!

What is the font technology (TrueType, OpenType, …)? Is the technology the same for all variants? I’ve read somewhere that recent LO has dropped support for “older” font technology.

I’ve tried with both TTF and OTF, with the same result :frowning:

In LibO 6.1, I can see all weights of the last Vollkorn fonts but “medium.” This is a known problem: LibO gets confused when a font offers many weights or shapes

Bug 77830 - PDF: slanted text becomes italic after roundtrip

Writer works great with “traditional” fonts offering the “normal, italic, bold and bold italic” combo, but if you need to use complex fonts such as Vollkorn (or any one that offers [optical sizes]( " Bug 112805 - Support for “size” (optical size) OpenType table "), for instance), maybe Writer is not for you. Depending on your document needs, XeTeX or Scribus will be a best fit.

“This is a known problem: LibO gets confused when a font offers many weights or shapes”

Thanks for the quick answer and clue, RGB-es! That sounds a good one, and would explain why only 3 of the family appear in my Writer’s drop-down font menu! I’ll try to remove the ones I don’t need and see if the needed one (Vollkorn Bold) show up. I’ll post here the result of this new try.

Thanks a lot!

After removing all but Regular, Bold and Italic files from this family, and making sudo fc-cache -f -v only a generic “Vollkorn” shows up at the drop-down menu. And now, the text which was created in some documents with “Vollkorn Bold” appears in “Vollkorn” but with Bold applied. Font name appears at the text toolbar rendered with italic, meaning that it’s a missing font. Still strange behaviour for me, but this will be an acceptable fix. ¡Muchas gracias, compañero! :slight_smile:

First, I suggest that whenever possible you get the fonts from the original source.
The fonts at 1001Fonts are v3.005 (2015-07-17), current fonts are v4.105 (2018-05-29).
There are now also ExtraBold and a Black fonts with italics.
So you may want use the newer fonts which have more features and fixes.
Second, these are great fonts; no issues in the fonts themselves.
All issues are LO.
Working 100% in LO on Windows.
Screen display, print output, and Export to PDF - all OK