Fonts not rendering properly on mac 10.14.6

I just installed LibreOffice 6.2 and when I open sheets, the fonts don’t render properly nor is the interface. See screenshots below.

image description
image description

When I’m entering data, the text renders properly in the cell:
image description

Once I am done and hit enter, the text goes fuzzy:
image description

Let me know if you need additional informations from me please.

If OpenGL is enabled, does it help to fix your problem, if you disable? To test, go to LibreOffice -> Preferences -> LibreOffice -> View -> Category: Graphics Output -> Option: Use OpenGL for all rendering. Untick and check again.

I tried with anti-alias enabled and disabled as well as with OpenGL enabled and disabled as well as different combinations of both. Same issue.

Did you restart LibreOffice after each attempt?

I did, I have even done a complete removal and fresh re-install.

I have an identical issue, have tried the suggestions mentioned above also. Running Radeon VII graphics

probably this is one of the known font rendering issues like tdf#122218