Fonts revert to Liberation Mono for all Template choices Although not Chosen

An ODT Writer document updated across many months for some reason today has begun to use Liberation Mono (LM) as the font for all choices of Paragraph Style selected for new text entry. In addition, using Ctrl+M (via either keyboard or Menu) also ends up with LM. I’ve checked, and LM is NOT the default font for any paragraph template. It all looks like a bug, yet I am unaware of any recent changes in the Desktop.

OS: PRETTY_NAME=“Devuan GNU/Linux 5 (daedalus)”
uname: Linux ng3 6.1.0-18-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.76-1 (2024-02-01) x86_64 GNU/Linux
menu:Tool | Options | Libreoffice Writer | Basic Fonts (Western) :

  • Default: DejaVu Serif :: 10pt
  • Heading: Open Sans :: 14pt
  • (all others) : Open Sans :: 10pt

The ODT file uses templates for everything throughout. I have checked them as much as I can & all seems well. I have many years of experience using LO but cannot track down what could possibly have gone wrong.

I’m looking for methods to diagnose the reason for this strange new behaviour. Can anyone assist?

Hello ! Glad to see you’re back. If you don’t want to expose publicly one example file and its template, send them to me through private mail. In Discourse, click on the icon left of my name, then Message button.