Fontwork disappears on re-opening a saved Writer file

Fontwork items work fine when first created or whilst document remains open.
At this stage, the thumbnail view on the recent items screen displays the graphic correctly.
However, on re-opening the document the fontwork disappears leaving some black text for the wording and a strange coloured shape. The shape varies depending on which style of fontwork had been selected eg. type 6 has a short line above and a long line below the text, type 7 has long yellow triangles above and below the text.

Tried upgrading to latest version, and a clean installation of on a brand new laptop, same problem.

However, on the new machine I have now noticed that it DOESN’T happen if the document is saved as .ODT format, only when saving as .DOCX.

Is this how it is supposed to work? Can it be fixed?
I keep encouraging people to use LibreOffice with ‘save as .docx’ by default in order to maintain compatibility with other people, so it would be helpful if this particular feature also worked.


There is reported bug about this matter LibreOffice can not save fontwork as docx

Thanks m.a.riosv, most helpful.
I’m guessing that as the bug was first raised in 2012, it’s not reached the top of anybody’s pile to get it fixed.

There is a comment that .DOC works okay, and I’ve just tested it. Looks like I’ll need to advise people to use that instead for the foreseeable future. Not ideal, but it is useable.

Thanks again.

I think better adding your comment to the bug, and if more people can add their comment, prehaps can get more attraction to be solved.

Okay, now done that. :slight_smile: