foreign language keyboard shortcuts

Years and years have gone by and computer software still has no idea how to deal with languages. I am so frustrated. The latest pain in my derriere is how the keyboard shortcuts in LibreCalc are in a foreign language. I have no idea where they came from. I have no idea how to change them to English.

image description

By the way, reCAPTCHA is the devil. Made me go through that hell twice.

May be you should set the keyboard to English and you’ll get the English names of the shortcuts. In fact the names are provided by the operating system and its keyboard settings and your question is not related to LibreOffice. You did not mention any technical and/or language details of you operating system, but I’d bet that you are using a keyboard language setting whose SHIFT key is called VAIHTO (whatever the language is - may be Finnish) in that language (or at least what developers of your operating system assume to be the name of the key in that language)

I’m sure you are right that it is due to the keyboard layout I have chosen to use. But the way Windows does languages is a joke and a frustration.

I use the Finnish keyboard layout with English as the language. What that means, is when I set up the keyboard, I selected English as the language. In my “Advanced keyboard settings”, the “Override for default input method” reads "English (United States) - Finnish, meaning English language, Finnish layout. Apparently, this is just too complicated for Windows to deal with.

I’m not a programmer of software, but I don’t agree that it is not a LibreOffice issue. It seems to me that LibreOffice made the choice to adopt Microsoft Windows Language Lunacy. Why adopt a system that does not work.

Anyway, thanks for the comment. I didn’t realize beforehand that this issue was related to my keyboard layout.

I’m sure you are right that it is due to the keyboard layout I have chosen to use. But the way Windows does languages is a joke and a frustration.

But then this site is wrong - you need to turn to Microsoft if you want your Finnish keyboard show. (But the behavior is the same on Linux system.

Thanks again. I’m surprised the Linux system has the same problem. Maybe, it’s a diabolical plan by the OS industry to force us to learn new languages.

It’s not a problem - if I use a german keyboard and have a german setting in my operating system. I expect key names to appear in my language (absolutely regardless of the UI language of my software). So the question is: Why do you use a Finnish keyboard, if everything should be in English?


see the following animation showing that the labeling of the shortcuts depends on your keyboard setting:

image description

Hope that helps.

Thanks. Because I don’t use multiple languages, I don’t have that language selection in my taskbar.

I learned from the first comment to my question that the problem does relate to the keyboard layout. I don’t know who made that comment. If you read my comment to that comment you see that I am set up for a Finnish keyboard layout, but the English language. I guess Windows just can’t believe my language choice.

I don’t know who made that comment.

It was me, as you can see.