form letter unable to connect to data source

Hi All, Once a year I load a write doc form, edit its text and try to print to PDF using a spreadsheet as the data source.
Usually I get a message “unable to connect to data source”.
I can generally get to the state that I can see the data in the data source explorer but when I go to print “unable to connect to data source” arrives.
I can create and delete databases and generally find my way round to get it working. This year nothing succeeds and the document fails to reassign a connection such that however long I wait I end up having to crash out and recover.
I use windows 10 (up to date) Libre Office 7.0.3. build 1d7547858d014d4cf69878db179d326fc3483e082
My files are stored on a NAS (Mycloud) and I have even tried storing the spreadsheet and document in the same local folder and my documents folder all with no success.
Unfortunately I have some knowledge but need a Dummies explanation.
Looking forward to a solution and next year.

Thanks for your reply. I can delete the database and its registration. I can make a new database, check its connections which pass so presumably available to other modules. I can open the form letter, change databases to the new one. The data is visible in the data source explorer for the form, the fields are the same but when I try and print the form it says its unable to connect. Is there somewhere in the form properties that can be edited to connect to the new database? Many thanks.

I have found the cause of the problem for me. When it comes up “unable to connect to data source” right click the database. Select registered databases, select the database. In my case the path starts off like this etc. I then delete this select new and browse to the same database and select. The path then starts of like this C:\User\Documents\etc.odb selecting this allows me to work. It can stay stable but might revert and you have to follow the whole process again when you reopen the writer doc. It might be a setting that is incorrect?
Occasionally it shows more than one registered database. In my case I only have one active and all the others have been deleted. So I delete those shown and exit to doc. Then close data sources explorer. Select edit databases, on the left select all databases if any and browse to the one you need and select, it will appear on the right. Select OK. start again opening the doc, data sources etc.


When using a spreadsheet as a source it is actually connected to a Base file. This Base file is registered so the data is available to other modules in the Data source explorer.

When you move any of the items to a different location, this link is broken. Unless placed back into the original places you need to start over or make the appropriate adjustments. The Base registration is accessed from the menu - Tools->options. Then under - LibreOffice Base → Databases you will find the registrations.


In reply to information placed in an answer (please change to comment or edit original question), if you create fields first based upon a table then change something, the fields will remain tied to the original designation.

You can verify/fix by right clicking on a field and select Edit. The field may be set to other than the selection wanted. Just select the correct field. You need to do this for all fields.

Thankyou, I’ll run through all 40+ fields individually as suggested.
Is there a shortcut as it seems that its only the connection that is broken as the fields haven’t changed?
Do I edit the question to solved when this works? (First question ever asked)?


There is no shortcut for the fields that I know of. Where the fields are pointing is part of the connection. Have recently tested similar for another post and the problem may be with one, many or all the fields. Need to check all.

No need to edit question to solved or even to close it. Others may come along in the future and add new information helpful to all.

However. if this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.