Format->Page->Sheet affects all sheets in a spreadsheet

OS Windows 7 Pro 64 bit patched

LibreOffice 64 bit

Under LibreOffice calc I created a spreadsheet years ago. Each sheet had its own page format for printing. Format->Page->Sheet->Print order

None of these sheets are that large.

Small sheets were set to “Fit print ranges to width/height” of one.

Larger sheets would normally be set to two pages high.

With the rare one left at 100%.

Recently, maybe with the update to but I’m not sure all the sheets must use the same page formatting. Small sheets are now spread over two pages or large sheet become unreadably small on one page.

My current solution is to format the page prior to printing, not an elegant solution. Next up would be breaking each printing style of sheet into their own spreadsheets.

Is there some option to let each sheet save its own page format or an option that removes that ability?

Thank you


I think what you’re experiencing now is intended behavior. Perhaps things were different in the past – I don’t know.

If you notice, when you open the page formatting dialog, it shows the page style, e.g. “Page Style: Default”. So this is really the same as opening the styles sidebar (F11), clicking the page style button (second from the left) and modifying the current (highlighted) style.

So, the solution is to create the page styles you need, then apply them to the appropriate sheets.

Thank you that solved the problem.

Using the F11 styles sidebar, selecting the page style button and then selecting the style worked.

calc had all but one of the formats I used there, so I created it and then selected a style for each sheet. Haven’t printed anything yet but the previews look good.