format paintbrush cannot change the format

  1. LO verison is and the module is writer.
  2. windows 7 enterprise sp1 64 bits.

I tried to use the format paintbrush for the following scenarios:
Q1). The paragraph 1 has the 123ABC456 characters and the ABC is bold, black, and its background color is yellow.
The paragraph 2 has the 789DEF012 characters and the DEF has blue color.
then I tried to use the format paintbrush from the A to the DEF, then the DEF has changed into bold, background color also changed into yellow, but the DEF’s text color is still blue.
Q2). I used format paintbrush from regular paragraph with bold , then using CTRL to the paragraph with numbered list , then the destination’s paragraph alreday changed into bold , but still kept the numbered list.

Do you know what the problem is ?
Thanks in advance.


I do not share your point of view: what you describe seems normal to me.

  1. Your first paragraph is black, the default color. The color of your second paragraph was overloaded. It is normal for me that the tool does not replace it. If you had changed the color of 1st paragraph (say red) tool would have applied this color to the second paragraph.
  2. Numbering is a paragraph attribute. To be removed in the context you describe:
  • select the regular paragraph including the paragraph mark: triple-click then Shift+Right arrow
  • click on paintbrush tool then click on the target paragraph by adding the Ctrl key

If you do not share these views, feel free to open to an enhancement request.


Q2 is still not working for me, for example as below
AAAAAAA → this paragraph has bold text
1.BBBBBBB → the paragraph is a numbered list
and I would like to select AAAAAAA then use format-paintbrush to 1.BBBBBBB , and even I used CTRL+click , the result still is 1.BBBBBBB has bold text, I’m wondering why the result is not BBBBBBB with bold text, since AAAAAAA is a regular paragraph. I’ve tested this scenario from MS word and the result is what I want, it’s BBBBBBB with bold text.

@lolax - You’re right, I do not use the same PC and I reproduce the problem with version A search Issues gives a list of identified bugs …