Format paintbrush not working in Calc, if same font

In Calc, I am trying to apply the formatting from one cell to others with the Format paintbrush, called “clone formatting”, without luck. A test spreadsheet is attached.

I read that you need to Ctrl click to apply character formatting and paragraph formatting. I have tried all eight combinations without luck.

No ctrl’s.
Ctrl click on first cell, click on the paintbrush, and click on the the target cell.
Ctrl click on first cell, ctrl click on the paintbrush, and click on the the target cell.
Ctrl click on first cell, click on the paintbrush, and ctrl click on the the target cell.
Click on first cell, ctrl click on the paintbrush, and click on the the target cell.
Click on first cell, ctrl click on the paintbrush, and ctrl click on the the target cell.
Click on first cell, click on the paintbrush, and ctrl click on the the target cell.
Ctrl click on first cell, ctrl click on the paintbrush, and ctrl click on the the target cell.

If it helps to understand this, the target cell that won’t change contains text originally copied from a web page.

Libreoffice calc format bug.ods

The problem is that there is a direct formatting of the text content and not of the cell. Perform a CTRL+M (removing any direct formatting) on cell B2 before you use clone formatting and everything works as designed.

Thanks. That works.

Of course, it would be preferable if this worked in one action. To an average user, there is not a meaningful distinction between format of a cell and format of the content of the cell. They just want both to look the same. The need to use ctrl-m first changes one action into four: click on cell, ctrl and m, click on cell again.

yepp - but what about users telling I never ever want a direct formatting being overwritten, because that’s why I used direct formatting. In addition as you told - you copied from a web site and here the story starts. If you had used Edit -> Paste Special -> Paste Special -> Selection: Unformatted Text then you would not be forced afterwards to use CTRL+M to delete that formatting to clone formatting to work again.

Ok, thanks. Perhaps the ctrl-click workaround could be applied in a future version of Calc? That is, if you ctrl-click the cell to clone the formatting, both the cell formatting and contents formatting could be applied together?

Ignoring that this page is neihter for posting enhancement requests (do that here) nor a place for discussion - which setting should win, if somebody tries to implement your proposal? The direct formatting or the cell style? Ask two users and you’ll get three answers:-)

I take all your points. If anyone else involved with updating LO reads this, I recommend just starting with this point of view: using the double action ctrl-click should “make both cells look the same”. If the first cell is shaded with borders, so should the second cell. If the first cell is Arial 12pt bold, so should the second cell. (Thanks so much for your gracious help and answers @anon73440385 - I consider the matter closed.)

For the records (according to comment of @LI1 )

The problem is that there is a direct formatting of the text content and not of the cell. Perform a CTRL+M (removing any direct formatting) on cell B2 before you use clone formatting and everything works as designed. To avoid to require a subsequent removal of direct formatting, insert any text using Edit -> Paste Special -> Paste Special -> Selection: Unformatted Text