Format: text shrunk in a box LO

I created the document with a MacBook Pro in LibreOffice 6.3 and saved it in .docx so that people with other programs could review it. Probably it was my mistake. The document contains about 7200 words and 3 embedded images. I have worked with the document multiple times. Every time I saved it, closed it and opened it without problems.

The problem came when I converted it to pdf using “Export direct as PDF”. The PDF was saved correctly (23 pages, end notes, pictures with description, etc) but the LO document was saved in a very strange format. Let’s say all the text was shrunk in a single box. Then, I have tried to delete the images, because I think the written text has gotten within the caption of an image. But they will stay there. No chance to delete annything except for the caption.

Please find a picture of the document in this link:

(Wrong) Solutions I have already tried:

  • If I reconvert the pdf to a doc file (using Adobe Reader), I get a more or less similar document, but with all the endnotes accumulated with no link to the word they relate, besides there are a lot of extra blanks.
  • I have tried saving a copy in .odt, but cannot open it because it says the document is corrupt.

I have searched the forum but was also unable to identify a similar problem. Would there be any other way to retrieve the original document?

Thank you.

Before you proceed you should save your work and try testing in a blank document, or a copy of the document you are working on.

I had a similar problem with using the “save Directly as PDF” option, where it seemed to overwrite the document I was saving with incorrect formatting. Can’t remember what I ended up doing but I think from that point onwards began using “export as PDFoption rather thanexport directly as PDF”, plus I started using frames instead of text boxes.. This seemed to solve my problems going forward, however I had to rearrange the content of the existing document into a new document but using frames instead of text boxes.

Don’t use text boxes for mixed images and text as they are not very adaptable overall. For 10 page document with text boxes here and there the document would appear fine and then go to export directly as PDF and all boxes are scattered and document layout was broken.

Try using frames instead of text boxes. I ended up setting a key-binding for insert frame interactively (on the Insert Menu). Set a key binding for this under (Tools menu → customize → keyboard tab. It’s under the insert category** using the Insert Frame Interactively

For me, I just copy and paste images directly into the document without placing them inside frames and this works well with surrounding annotation (inside frames). Stacking/layering of frames works fine in order add multiple pieces of text in close proximity) to an image but the options need to be configured depending on how you wish it to appear.

With frames you can insert an image then insert a frame to position text around
If you cannot see the cursor after you insert the frame try pressing F2.

  • There are wrapping options for the frame which you can apply to the frame style rather than having to do it for individual frames. Before applying these options to a style, test this on individual frames to see if it works for you then you can apply it to the actual frame style. (click on a frame, F11 to open styles pane, right-click on frame style and select modify). Under wrap menu select wrap through, then you might try ticking in background. You can try these options separately to see how it behaves.

  • If you are experiencing issues with text positioning and layout you might also try playing around with the width options of an individual frame to the Type tab. If it works, then apply it to the frame style as indicated above.

  • Beware that there are two styles surrounding frames. There is frame style and frame contents style. You might try playing around with both in a test document to get a better idea of what each do.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question.

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Many thanks for your well-explained comment. This is good to prevent it happen next time.